Task Running Date Incorrect

Please post your support questions here.

Moderators: Eraser DevTeam, Eraser Moderators

Task Running Date Incorrect

Postby mtbsw101 » Wed Jul 20, 2011 8:08 am

I have downloaded Eraser onto my new Asus laptop - As of Tuesday 7/18/11 my task log is reading 24 hours in advance - I run my task at 12:01am, Daily - Today, Wednesday, 7/20/11
at 1:07 am my Task Log reads "Thursday July 21 -2011 - Completed - Could you advise me as to how to reset the running date back to Real Time -
mtbsw101
 
Posts: 6
Joined: Wed Jul 20, 2011 7:44 am

Re: Task Running Date Incorrect

Postby DavidHB » Wed Jul 20, 2011 11:33 am

Eraser, as far as I know, uses the system time, so it is worth checking your Windows time settings (which can sometimes misbehave). What time zone are you in?

David
I am not an Eraser programmer, but a long-time user; my views may not be the same as those of the Eraser programming team.
Before posting, please read the top 4 topics in the Eraser FAQ, which already provide many of the answers users need.
DavidHB
Eraser Wizard
 
Posts: 2166
Joined: Sat Jan 23, 2010 8:10 pm
Location: Isle of Wight, UK

Re: Task Running Date Incorrect

Postby mtbsw101 » Thu Jul 21, 2011 8:58 am

David - I am in Pacific Time, checked computer...running real time, reset scheduale on eraser...let's see if it complies...thanks for your quick response -Chris
mtbsw101
 
Posts: 6
Joined: Wed Jul 20, 2011 7:44 am

Re: Task Running Date Incorrect

Postby mtbsw101 » Fri Jul 22, 2011 7:33 pm

David- I am in the Pacific time zone....thanks for your quick reply....I checked my computer date/time settings...they are real time relevent

David - Time is still running 24hrs in advance....Personally I 'm not that concerned with what the task log date reads as I am that the program runs daily - I have it set to run at 12:01 am daily ......is that too close to the margin ?????

While I have you on the line - My last Task Log read " Error - Program does not have the required permissions to erase unused disk space on disk -Run program as an
Administrator and retry operation " I read through the entire manuel and have no idea how to set this up (I am tech chalenged) - Could you please walk me through the procedure or guide me to where I can learn how do do this...I run Windows 7 on an Asus laptop - Thank you so much for your quick response and help with these concerns -
I am a retired private investment banker - You attention to detail speaks volumes for you and the product you support - Again thanks, Chris
mtbsw101
 
Posts: 6
Joined: Wed Jul 20, 2011 7:44 am

Re: Task Running Date Incorrect

Postby DavidHB » Fri Jul 22, 2011 9:13 pm

It's just possible that the timing issue is a bug; I'll draw it to Joel's attention.

Now the 'Run as Administrator' thing I can help with :) . Using the link in my signature block, go to the FAQ and read the topic "Getting to know Eraser 6". You should find it generally useful, but it also contains specific guidance on running Eraser as Administrator.

David
I am not an Eraser programmer, but a long-time user; my views may not be the same as those of the Eraser programming team.
Before posting, please read the top 4 topics in the Eraser FAQ, which already provide many of the answers users need.
DavidHB
Eraser Wizard
 
Posts: 2166
Joined: Sat Jan 23, 2010 8:10 pm
Location: Isle of Wight, UK

Re: Task Running Date Incorrect

Postby mtbsw101 » Mon Jul 25, 2011 12:11 am

David ....I did as you suggested and even printed out your instructions, which are exceptionally clear and concise - I have Norton 360, I disabled it.....I backup with
Carbonite, I paused it....I then went step by step as you direct - I first right clicked Eraser on the start menu - clicked on, run as administrator, clicked on Yes when asked in the next window if I wanted to allow Eraser to run - Then appears the Eraser window,click drop down -New Task, click drpodown on next window - clicked on Pseudorandom, click button" erase empty space",click OK...window appears has Not Qued, right click, click run now...comes up " completed with errors", click view log, we are right back to "no permissions, run as administrator......which is where we started.......ya gotta love tecnology....I am not a big fan of Windows 7....I ran 98 forever with Eraser and never had any problems....SO, my friend, What doth thee next suggest....Should I uninstal Eraser and reinstal it ? :roll: Thanks soo much for your time David....Chris
mtbsw101
 
Posts: 6
Joined: Wed Jul 20, 2011 7:44 am

Re: Task Running Date Incorrect

Postby DavidHB » Mon Jul 25, 2011 11:45 am

Don't uninstall Eraser. This is a Windows (7 and Vista) feature, or problem depending on how you look at it.

Here are the instructions as they appear in the FAQ post:
"To do this, first close the running instance of Eraser by right-clicking on the small Eraser icon in the System Tray at the right hand end of the Taskbar and selecting Exit Eraser. Then right-click on the Eraser program icon on the Desktop or the Start Menu and select Run as Administrator."

As I read your post, you did not close the running instance of Eraser before re-running it as Administrator; in that case, Windows, bless it, just ignores the instruction to run elevated, so you get the same error as before.

David
I am not an Eraser programmer, but a long-time user; my views may not be the same as those of the Eraser programming team.
Before posting, please read the top 4 topics in the Eraser FAQ, which already provide many of the answers users need.
DavidHB
Eraser Wizard
 
Posts: 2166
Joined: Sat Jan 23, 2010 8:10 pm
Location: Isle of Wight, UK

Re: Task Running Date Incorrect

Postby mtbsw101 » Mon Jul 25, 2011 8:52 pm

David - I forgot to mention that I tried to do as instructed with regard to , right clicking the eraser icon which is not on the right but on the left of my system tray at the bottom of my screen....ok, when I right click all I get is, unpin this program from taskbar and eraser, I right click on eraser and I get,open,run as administrator,unpiun,and properties....no Exit Eraser... there is an arrow on the right side of the tray, click on it and I get icon notifications and an option to turn icons on/off- when I click on this I get no option regarding Eraser....things like clock, power volume -
David - Your instructions are impecable, a six year old could follow them....no where can I find an option to " exit eraser" Any ideas ? Again thanks so much for your help
Chris
mtbsw101
 
Posts: 6
Joined: Wed Jul 20, 2011 7:44 am

Re: Task Running Date Incorrect

Postby DavidHB » Mon Jul 25, 2011 10:05 pm

There are several possibilities here, so bear with me ...

The System Tray is the section of the taskbar at the far right, near the clock, with a number of tiny icons, and the Eraser icon (a smaller version of the desktop icon, with a tooltip saying 'Eraser') should be there. If it isn't, start the Eraser program, to see if it appears. If it doesn't, do the following.

Right click in the system tray, but not on an icon (to the left of the clock is good). You should get a menu with the option 'Customise notification icons': select this option. If the tray is so full of icons that there is no free space, click on the little up arrow on the left of the tray; this gets you a window with more icons and a link to 'Customise', which does the same thing. In the window that appears, find the entry for Eraser, and (if necessary) change its behaviour to 'show icon and notifications'. The icon should then certainly show.

Once the icon shows, right-clicking on it gives you 3 options, the last of which is 'Exit Eraser'. That's the one you want.

Good luck!

David
I am not an Eraser programmer, but a long-time user; my views may not be the same as those of the Eraser programming team.
Before posting, please read the top 4 topics in the Eraser FAQ, which already provide many of the answers users need.
DavidHB
Eraser Wizard
 
Posts: 2166
Joined: Sat Jan 23, 2010 8:10 pm
Location: Isle of Wight, UK

Re: Task Running Date Incorrect

Postby mtbsw101 » Thu Jul 28, 2011 2:55 am

David -I got it!!!!!!!!!! finally got icon to show up on right side of tray ...restarted computer.....BINGO.....Thanks David
mtbsw101
 
Posts: 6
Joined: Wed Jul 20, 2011 7:44 am

Re: Task Running Date Incorrect

Postby remmons » Thu Jul 28, 2011 1:07 pm

DavidHB wrote:It's just possible that the timing issue is a bug; I'll draw it to Joel's attention.

Now the 'Run as Administrator' thing I can help with :) . Using the link in my signature block, go to the FAQ and read the topic "Getting to know Eraser 6". You should find it generally useful, but it also contains specific guidance on running Eraser as Administrator.

David


Thanks for the info. I was having the same problem as the original poster. I was right clicking the launch icon, and selecting "Run as administrator", but still getting the "does not have required permissions" error. I did not realize I had to shut down Eraser from the system tray. I followed your instructions, and the program ran.

My problem was solved. Thanks again.
remmons
 
Posts: 2
Joined: Thu Jul 28, 2011 12:52 pm

Re: Task Running Date Incorrect

Postby DavidHB » Thu Jul 28, 2011 1:55 pm

Glad to help. I too get caught out by this from time to time. Hopefully the next version of Eraser will have a more elegant means of getting round the Windows restrictions. Some utilities (CCleaner, for example) are always run elevated, but that isn't really an option for Eraser, as some erasing is best done at the user level.

David
I am not an Eraser programmer, but a long-time user; my views may not be the same as those of the Eraser programming team.
Before posting, please read the top 4 topics in the Eraser FAQ, which already provide many of the answers users need.
DavidHB
Eraser Wizard
 
Posts: 2166
Joined: Sat Jan 23, 2010 8:10 pm
Location: Isle of Wight, UK

Re: Task Running Date Incorrect

Postby Joel » Wed Aug 31, 2011 7:47 am

...apologies for being one month late... but has the date issue been solved? Yes, David is right, Eraser uses the system date and time (that's really the only date and time available, isn't it?)
Be sure to read the FAQ before posting. If you found this application useful, please contribute to Eraser's development.

I develop Eraser but I am not an employee of Heidi Computers Ltd. My views do not represent those of Heidi Computers Ltd.
Don't PM or Email me questions: they won't be answered any faster than on the forum and knowledge won't be accessible by all.
User avatar
Joel
Eraser DevTeam
 
Posts: 3688
Joined: Sat Aug 19, 2006 12:16 am
Location: Singapore

ERASER SCHEDULER IS NOT SHOWING CORRECT RECURRENT DATES

Postby cybersun » Thu Sep 08, 2011 12:48 am

HELLO, new to this ERASER SW.

I have set up an ERASE JOB to run on the SECOND (2ND) day each month.

Now the Scheduale task window shows:

DAILY - Every Day

and also

MONTHLY DAY 2 EVERY MONTH

and in the ERASER MAIN SCREEN it SHOWS the ERASE JOB will run on September 30.

Somehting lokks wrong.

Please advise

PS: I downloaded the latest version (nightly...)
Should I download the first one 6.0...

SCHEDULER ERROR.JPG
SCREEN SHOT OF THE SCHEDULER ERROR SHOWING SEPTEMBER 30 WHEN IT SHOULD BE OCTOBER 2. ALSO SHOWS THAT BOTH DAILY AND MONTHLY ARE ACTIVATED.
cybersun
 
Posts: 5
Joined: Wed Sep 07, 2011 7:10 pm

Re: Task Running Date Incorrect

Postby Joel » Sat Sep 10, 2011 6:27 am

Click on Weekly, does the radio button shift to that being selected?

Which version of Eraser are you running?
Be sure to read the FAQ before posting. If you found this application useful, please contribute to Eraser's development.

I develop Eraser but I am not an employee of Heidi Computers Ltd. My views do not represent those of Heidi Computers Ltd.
Don't PM or Email me questions: they won't be answered any faster than on the forum and knowledge won't be accessible by all.
User avatar
Joel
Eraser DevTeam
 
Posts: 3688
Joined: Sat Aug 19, 2006 12:16 am
Location: Singapore

Next

Return to Eraser Support

Who is online

Users browsing this forum: Bing [Bot] and 2 guests