need help removing 5.8.8 remnants

Please post your support questions here.

Moderators: Eraser DevTeam, Eraser Moderators

need help removing 5.8.8 remnants

Postby palancar » Tue Mar 06, 2012 7:37 pm

I use the newest Eraser 6 and its great.

I tried to remove 5.8.8 from one of my computers. Since it is always on I couldn't use the uninstall program in control panel even when running in full Admin mode. I manually deleted the Eraser folder from C and then went to system32 and deleted the eraser dll's using a "live CD" to do it. I thought I had it "out of sight" but then I noticed that the recycle bin still has all those wipe options in the menu. I cannot figure out how to get rid of them and could use a steer.

Can someone tell me what file(s) are responsible for loading those menu options in my recycle bin menu? I want to get rid of them - badly.

As it is I'll likely have some registry "leftovers" hanging around but I can live with those. I can't live with looking at those recycle menu items every single time I clean out the bin.

Suggestions please.
palancar
 
Posts: 14
Joined: Mon Dec 12, 2011 9:49 pm

Re: need help removing 5.8.8 remnants

Postby palancar » Tue Mar 06, 2012 8:56 pm

Joel,

I would have no problem re-installing 5.8.8 if it would help to uninstall it properly. 5.8.8 appears to always be ON. Is there a trick/method to removing 5.8.8 from the Vista 64 start menu? With it appearing to be ON, the uninstall program will not launch. When I boot Vista I don't touch Eraser in any way but it is still ON according to the control panel. That is why I did the manual removal. I know Eraser 6 has come a long way, which is why I now use it exclusively.

I simply want to install 5.8.8 so that I can remove it using control panel's uninstall process. Unless I can turn it OFF the reinstall will be of no avail.


btw -- the context menu items are gone from right click of files/folders. I only see the recycle bin context menus.
palancar
 
Posts: 14
Joined: Mon Dec 12, 2011 9:49 pm

Re: need help removing 5.8.8 remnants

Postby DavidHB » Tue Mar 06, 2012 10:44 pm

It's some time since I used 5.8.8, but in my recollection the only running process is the scheduler. As far as I remember, this can be switched off by unchecking the option to start Eraser with Windows, then restarting. If that does not work, uninstall Eraser 6, restart and see if Eraser 5 will uninstall; if it won't (running process), use the Task Manager to look for an Eraser process, stop it, and re-try the uninstall.

I suspect that the origin of your problem is that you installed Eraser 6 without uninstalling Eraser 5 first; your problem with the context menu suggests that Eraser 5 is conflicting with Eraser 6. I suggest that, even if my first suggestion works, you should uninstall Eraser 6, then Eraser 5 (if there is still an uninstall option for it), then ideally delete all traces of Eraser you can find in the file system and the Registry before reinstalling Eraser 6. That is the only way you will leave your machine with a functioning Eraser 6 and no chance of anything left over from Eraser 5 interfering with it.

David
I am not an Eraser programmer, but a long-time user; my views may not be the same as those of the Eraser programming team.
Before posting, please read the top 4 topics in the Eraser FAQ, which already provide many of the answers users need.
DavidHB
Eraser Wizard
 
Posts: 2166
Joined: Sat Jan 23, 2010 8:10 pm
Location: Isle of Wight, UK

Re: need help removing 5.8.8 remnants

Postby Joel » Tue Mar 06, 2012 11:20 pm

Haha, this is the tricky one.

Trigger the uninstaller from Add/Remove Programs (or Programs and Features if you're using Vista+); when it complains that Eraser is currently running, open up Task Manager and kill explorer.exe. Leave Task Manager running. Click OK with the uninstaller, then when it is complete, restart Explorer (use File>Run from Task Manager and use "explorer" as the command)

This is because the entire Eraser library is loaded into Explorer's address space because of the context menu.
Be sure to read the FAQ before posting. If you found this application useful, please contribute to Eraser's development.

I develop Eraser but I am not an employee of Heidi Computers Ltd. My views do not represent those of Heidi Computers Ltd.
Don't PM or Email me questions: they won't be answered any faster than on the forum and knowledge won't be accessible by all.
User avatar
Joel
Eraser DevTeam
 
Posts: 3688
Joined: Sat Aug 19, 2006 12:16 am
Location: Singapore

Re: need help removing 5.8.8 remnants

Postby DavidHB » Wed Mar 07, 2012 10:56 am

Joel - I am beginning to remember this advice now. Is your reference in the previous post to the Eraser 6 or Eraser 5 uninstaller? I'd guess that one would need to run both uninstallers (if present and functional) to clear the decks for a good, clean install of Eraser 6. Is that correct?

David
I am not an Eraser programmer, but a long-time user; my views may not be the same as those of the Eraser programming team.
Before posting, please read the top 4 topics in the Eraser FAQ, which already provide many of the answers users need.
DavidHB
Eraser Wizard
 
Posts: 2166
Joined: Sat Jan 23, 2010 8:10 pm
Location: Isle of Wight, UK

Re: need help removing 5.8.8 remnants

Postby Joel » Wed Mar 07, 2012 11:19 am

Eraser 5. Eraser 6's uninstaller can handle locked files perfectly fine.
Be sure to read the FAQ before posting. If you found this application useful, please contribute to Eraser's development.

I develop Eraser but I am not an employee of Heidi Computers Ltd. My views do not represent those of Heidi Computers Ltd.
Don't PM or Email me questions: they won't be answered any faster than on the forum and knowledge won't be accessible by all.
User avatar
Joel
Eraser DevTeam
 
Posts: 3688
Joined: Sat Aug 19, 2006 12:16 am
Location: Singapore

Re: need help removing 5.8.8 remnants

Postby palancar » Wed Mar 07, 2012 5:55 pm

Joel and David,

Thanks for the directions. I used the method Joel described and 5.8.8 uninstalled without a hitch. I had never considered killing explorer as the problem. When I killed explorer the uninstaller worked great. Eraser 6 is working fine too. I didn't uninstall it. In fact I installed 6 in a virtual space so that I can mount it when needed.

I don't really want 6 running all the time so use of a virtual container for my install solves that issue for me. I just mount the volume when I need to erase and clean!!

Eraser 6 is awesome. Great piece of software.
palancar
 
Posts: 14
Joined: Mon Dec 12, 2011 9:49 pm

Re: need help removing 5.8.8 remnants

Postby DavidHB » Wed Mar 07, 2012 8:01 pm

I'm glad it worked, and have learned quite a bit from the exchanges.

The use if the virtual space is rather neat. Actually, Eraser starts quite happily if you just use msconfig to prevent the process starting up with Windows. When you use Eraser the process starts, and remains active unless you explicitly kill it (from the System Tray). Joel has agreed that, as in Eraser 5, there will be an option in eraser 6.2 to prevent the process running all the time, which is only needed for time sceduled erasing.

David
I am not an Eraser programmer, but a long-time user; my views may not be the same as those of the Eraser programming team.
Before posting, please read the top 4 topics in the Eraser FAQ, which already provide many of the answers users need.
DavidHB
Eraser Wizard
 
Posts: 2166
Joined: Sat Jan 23, 2010 8:10 pm
Location: Isle of Wight, UK

Re: need help removing 5.8.8 remnants

Postby palancar » Wed Mar 07, 2012 10:06 pm

David,

Yep the virtual space method works well. As a precaution I went ahead and deleted 6 and created a new virtual volume (whopping 5 meg - LOL) on my desktop to re-install 6. It went well.

Actually though I like the idea of using msconfig to configure Eraser 6 NOT to come on until/unless I actually use the program. Manually turning it off via system tray/exit is no big deal at all.

Using Vista 64 as an OS on a couple of machines. I am going to do some reading about using your approach as well. Strictly from a convenience standpoint; at this time I have to "mount" the virtual space to access Eraser. I use a simple password because security on this volume is moot. Merely clicking a desktop icon to initiate Eraser would be more convenient.

What steps did you take to config your machine using your approach - if you remember them? Joel?


ps ---- any time table on the 6.2 release????
palancar
 
Posts: 14
Joined: Mon Dec 12, 2011 9:49 pm

Re: need help removing 5.8.8 remnants

Postby palancar » Wed Mar 07, 2012 10:38 pm

msconfig was sooooo easy. Thanks for the suggestion. It'll actually be easier than opening a virtual volume.

Much appreciated!!
palancar
 
Posts: 14
Joined: Mon Dec 12, 2011 9:49 pm

Re: need help removing 5.8.8 remnants

Postby DavidHB » Wed Mar 07, 2012 11:13 pm

palancar wrote:What steps did you take to config your machine using your approach

I think, exactly what you did ... :)

palancar wrote:ps ---- any time table on the 6.2 release????

It's probably better not to ask ... :cry:

David
I am not an Eraser programmer, but a long-time user; my views may not be the same as those of the Eraser programming team.
Before posting, please read the top 4 topics in the Eraser FAQ, which already provide many of the answers users need.
DavidHB
Eraser Wizard
 
Posts: 2166
Joined: Sat Jan 23, 2010 8:10 pm
Location: Isle of Wight, UK

Re: need help removing 5.8.8 remnants

Postby Joel » Thu Mar 08, 2012 12:15 am

I'd put my finger on a 6 to 9 man-month effort... but remember that man-hours assume that I'm working on this full time, which I am not...
Be sure to read the FAQ before posting. If you found this application useful, please contribute to Eraser's development.

I develop Eraser but I am not an employee of Heidi Computers Ltd. My views do not represent those of Heidi Computers Ltd.
Don't PM or Email me questions: they won't be answered any faster than on the forum and knowledge won't be accessible by all.
User avatar
Joel
Eraser DevTeam
 
Posts: 3688
Joined: Sat Aug 19, 2006 12:16 am
Location: Singapore

Re: need help removing 5.8.8 remnants

Postby william070707 » Fri Mar 09, 2012 11:37 pm

I too have the similar problem,went through the thread and did same told here,finally it is resolved :geek:
User avatar
william070707
 
Posts: 15
Joined: Thu Feb 23, 2012 4:43 pm

Re: need help removing 5.8.8 remnants

Postby palancar » Mon Mar 12, 2012 7:53 pm

See we can all learn from each other. LOL!!
palancar
 
Posts: 14
Joined: Mon Dec 12, 2011 9:49 pm

Re: need help removing 5.8.8 remnants

Postby DavidHB » Mon Mar 12, 2012 9:56 pm

palancar wrote:See we can all learn from each other. LOL!!

... which is just what the forum is for :)

David
I am not an Eraser programmer, but a long-time user; my views may not be the same as those of the Eraser programming team.
Before posting, please read the top 4 topics in the Eraser FAQ, which already provide many of the answers users need.
DavidHB
Eraser Wizard
 
Posts: 2166
Joined: Sat Jan 23, 2010 8:10 pm
Location: Isle of Wight, UK


Return to Eraser Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Yahoo [Bot] and 3 guests