Ticket #118 (closed defect: worksforme)

Opened 6 years ago

Last modified 6 years ago

Verify has problems erasing files with long filenames

Reported by: chris12923 Owned by:
Priority: minor Milestone: Eraser 5.8.7
Component: Core Version:
Keywords: Cc:
Processor Architecture: Blocked By:
Blocking: Operating System:

Description

Create a .txt file with vista maximum filename length
Inside the .txt file enter any text you like (I used about 50 of any character)
Now I chose the DOD 3 pass wipe and started to wipe heres where I get mixed results..
Sometimes it wiped fine, sometimes it would only make one pass and then say it was complete and the file would be removed from where I had it, then fairly frequently it would complete all passes and say it was finished but the file remained on my desktop and any attempts to access it would bring a windows popup saying that it couldn't find the file...

I attached a screen cap.

Blocking

IdSummaryMilestone
#118Verify has problems erasing files with long filenamesEraser 5.8.7

Blocked by

IdSummaryMilestone
#118Verify has problems erasing files with long filenamesEraser 5.8.7

Attachments

screenie.jpg (74.0 KB) - added by chris12923 6 years ago.

Change History

Changed 6 years ago by chris12923

comment:1 Changed 6 years ago by chris12923

Strange but after I tried another test same as above but with an actual .jpg file I used DOD 7 pass and it worked properly but as soon as it erased the .jpg the other two files I told you about above also were removed at the same time.. It was almost like the desktop wasnt refreshing earlier. I'll see what you think and if you can repro it and if not I will look into it further.

comment:2 Changed 6 years ago by Joel

  • Status changed from new to closed
  • Resolution set to worksforme

The Vista shell maximum length is actually 260 chars (as with all Windows versions since 95 and NT). NTFS is capable of 32767 chars (approximately). Eraser will only support the shell maximum as we rely on the shell APIs quite a fair bit, v6 definitely will not support the full 32767 as .NET classes do not allow it.

The desktop not refreshing bit is fully possible. I see old files remaining on disk after an erase until I force a refresh too.

Note: See TracTickets for help on using tickets.