Ticket #139 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

Right clicking recycle bin two errors.

Reported by: Overwriter Owned by: Joel
Priority: major Milestone: Eraser 6.0
Component: Core Version: 6.0.4.875
Keywords: Cc:
Processor Architecture: Blocked By:
Blocking: Operating System:

Description

XP Pro SP3 .net 3.5

Eraser V6 Beta 3

I right clicked the recycle bin which contained a single .txt file. Eraser reported it had to close and then crashed.

I restarted.

I tried again and this time Eraser added the task to the schedule as with my other report when trying to right click and erase a file elsewhere. The schedule said it had completed.

The .txt file was not in the recycle bin, however the recycle bin full icon remained.

I restarted but the full bin icon remained. Only using Ccleaner removed the full icon and restored things to normal.

Blocking

IdSummaryMilestone
#139Right clicking recycle bin two errors.Eraser 6.0

Blocked by

IdSummaryMilestone
#139Right clicking recycle bin two errors.Eraser 6.0

Change History

comment:1 Changed 6 years ago by Joel

  • Version set to 6.0.3.847
  • Milestone set to Eraser 6.0

comment:2 Changed 6 years ago by Joel

  • Status changed from new to accepted
  • Owner set to Joel

Sounds like we're not emptying the recycle bin. After the erase pass completed are the files still inside the bin? I know the icon is still displaying the full icon, but is the file still inside?

comment:3 Changed 6 years ago by Overwriter

No the .txt file was not in the recycle bin but the bin icon showed full.

comment:4 Changed 6 years ago by Joel

Partially fixed in #850. I can't reproduce the crash properly. I get it occasionally but can't put a finger as to why. Eraser was started by the system at log on, right?

comment:5 Changed 6 years ago by Joel

  • Status changed from accepted to pending

comment:6 Changed 6 years ago by Overwriter

  • Status changed from pending to new

“Eraser was started by the system at log on, right?”

Yes it was.

"I get it occasionally"

The bug is also intermittent with me also.

comment:7 Changed 6 years ago by Joel

  • Status changed from new to closed
  • Resolution set to fixed

The crash has been r866. It won't happen but the side effect is that Eraser won't know whether to display the balloon to the user.

comment:8 Changed 6 years ago by Overwriter

  • Status changed from closed to reopened
  • Resolution fixed deleted

Sorry but I am still getting the recycle bin error. Same setup but with V6 Beta4.

comment:9 Changed 6 years ago by Joel

What's the recycle bin error? The crash or the recycle bin icon?

comment:10 Changed 6 years ago by Overwriter

  • Version changed from 6.0.3.847 to 6.0.4.875

A bit of both, sometimes I right click the recycle bin icon and select erase and nothing happens. Then I try again and sometimes it will work ok and others it will pop a box up saying Eraser has to close.

Other times eraser says the scheduled task has been done but with errors. That is usually when I am left with an empty recycle bin but a full bin icon.

Nothing clears it unless I run Ccleaner on the bin afterwards.

I have tried with different file types but nothing seems consistent. It can work correctly several times in a row just sometimes failing.

comment:11 Changed 6 years ago by Overwriter

I have the Eraser error log.

The system cannot find the file specified. (Exception from HRESULT: 0x80070002)

comment:12 Changed 6 years ago by Joel

  • Status changed from reopened to accepted

Yea, it's unpredictable. If you have a full recycle bin icon but it's empty all you have to do is to empty the recycle bin using Explorer. I find the problems usually with XP machines, my Vista desktop and laptop doesn't have the problem. I'll look into it when time permits.

comment:13 Changed 6 years ago by Overwriter

Totally unrelated as it is an unsupported OS at the moment but someone using Win7 Beta reports the intermittent right click recycle bin error.

comment:14 Changed 5 years ago by Joel

  • Status changed from accepted to closed
  • Resolution set to fixed

Okay, so the recycle bin icon should have been fixed and the only problem left should be that of Eraser crashing when using the shell extension, which is #195.

I'll close this ticket.

comment:15 Changed 5 years ago by Joel

  • Status changed from closed to reopened
  • Resolution fixed deleted

Then again, I think we can replace the labels on the dialog to make it more informative before I close this ticket.

comment:16 Changed 5 years ago by Joel

  • Status changed from reopened to accepted

comment:17 Changed 5 years ago by Joel

  • Status changed from accepted to closed
  • Resolution set to fixed

Oops, wrong ticket.

Note: See TracTickets for help on using tickets.