Ticket #192 (closed defect: duplicate)

Opened 6 years ago

Last modified 6 years ago

Scheduler stops if a file in the queue is locked

Reported by: jackjack Owned by: Joel
Priority: blocker Milestone: Eraser 6.0
Component: Core Version: 6.0.4.875
Keywords: Cc:
Processor Architecture: Blocked By:
Blocking: Operating System:

Description

If a folder listed in schedule contains a file that is locked by another program, eraser will stop the scheduled task rather than skip over the file and erase all other files in the folder.

Eraser should be able to intelligently handle locked files by either 1 skipping over them or 2 being scheduled for removal on reboot before continuing on to remove the remainder of files in the scheduled task

Blocking

IdSummaryMilestone
#192Scheduler stops if a file in the queue is lockedEraser 6.0

Blocked by

IdSummaryMilestone
#192Scheduler stops if a file in the queue is lockedEraser 6.0

Change History

comment:1 Changed 6 years ago by Walda

  • Priority changed from major to blocker

Confirmed. This is really dangerous. Sensitive data can be left unerased unnoticed while the user is away. This mustn't be in the final release. Therefore changing priority to blocker.

Example dir where this will certainly lead to data being left unerased "C:\Users\<username>\AppData?\Local\Temp\"

Eraser will also stop when sending a list of files via the shell extension to Eraser, the task will stop at the locked file leaving the following files untouched.

comment:2 Changed 6 years ago by Walda

  • Type changed from enhancement to defect

comment:3 Changed 6 years ago by Joel

  • Status changed from new to accepted
  • Owner set to Joel
  • Milestone set to Eraser 6.0

comment:4 Changed 6 years ago by Joel

  • Status changed from accepted to closed
  • Resolution set to duplicate

Duplicate of #177.

comment:5 Changed 6 years ago by Joel

Fixed in r894.

comment:6 Changed 6 years ago by Joel

And a bit more in r895.

Note: See TracTickets for help on using tickets.