Ticket #202 (closed enhancement: wontfix)

Opened 6 years ago

Last modified 5 years ago

Popup status windows instead of tooltips for tasks

Reported by: Walda Owned by:
Priority: major Milestone: Eraser 6.0
Component: User Interface (UX) Version: 6.0.4.875
Keywords: Cc:
Processor Architecture: Blocked By:
Blocking: Operating System:

Description

I miss the status window of v5. Please bring it back, especially for erasing files via shell extension.

Blocking

IdSummaryMilestone
#202Popup status windows instead of tooltips for tasksEraser 6.0

Blocked by

IdSummaryMilestone
#202Popup status windows instead of tooltips for tasksEraser 6.0

Change History

comment:1 Changed 5 years ago by Joel

  • Status changed from new to closed
  • Resolution set to wontfix

I'm not sure where I wrote it, but the reason I've designed it this way is simple - Windows as a operating system is moving away from synchronous 'blocking' dialogs to asynchronous ones which allow other user activity while erasures are taking place. It's to allow users to continue with their work while waiting for an erase to complete. The user should not be forced to stop doing what he's doing just because he requested an erase.

This is by design, you'll have to adapt to it, I'm afraid.

Joel

comment:2 Changed 5 years ago by Joel

Oh, if you want status reports, you can open the main Eraser window to look at the task list. It's there.

comment:3 Changed 5 years ago by Walda

I usually erase only a few or single files via the explorer's context menu. That's done in a few seconds. Hardly enough time to change to another application, thus there's no interruption of my work flow. In fact looking at the status window is part of my work flow.

And when erasing much more bytes (of course again, via shell extension), I'd LOVE to get noticed by a popup window. I easily overlook the notification area tooltips during my work flow, not just Eraser's.

comment:4 Changed 5 years ago by Joel

Oh yes, another reason I did it in this manner is to support erasing unused space from the shell extension; it won't work in Vista+ unless UAC is disabled (which isn't recommended)

Note: See TracTickets for help on using tickets.