Ticket #216 (closed enhancement: fixed)

Opened 5 years ago

Last modified 5 years ago

Erase from file context menu doesn't work if Eraser is Run as Administrator

Reported by: Vista UAC Owned by: Joel
Priority: major Milestone: Eraser 6.0
Component: Core Version: 6.0.5.1114
Keywords: Cc:
Processor Architecture: Blocked By:
Blocking: Operating System:

Description

If 6.0.5.1114 is set to Run as an Administrator on Vista with UAC, then attempting to Erase a file says it can't start Eraser (even though it's running). Works if Eraser isn't set to Run as an Administrator.

Change History

comment:1 Changed 5 years ago by Joel

  • Status changed from new to accepted
  • Owner set to Joel
  • Type changed from defect to enhancement
  • Milestone set to Eraser 6.0

This is expected behaviour. This is because when Eraser is already running at a higher privilege level than the new instance (which is spawned to delete the file) the interprocess communications don't work (because of Vista restrictions)

However I can work on it to make sure that the process works more smoothly in future.

comment:2 Changed 5 years ago by Joel

  • Status changed from accepted to closed
  • Resolution set to fixed

Implemented in r1153.

Note: See TracTickets for help on using tickets.