Ticket #234 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

Exiting Eraser background process issue.

Reported by: viktor Owned by: Joel
Priority: major Milestone: Eraser 6.0
Component: User Interface (UX) Version: 6.0.5.1114
Keywords: Cc:
Processor Architecture: i386 (32-bit) Blocked By:
Blocking: Operating System: Windows 7

Description

When the 'nuke icon' starts up on Windows boot, right-clicking the icon and clicking exit appears to have no effect.

When right-clicking again, the menu re-appears but sticks, becomes non-interactive but remains.

The only way to fully exit the background process was to fire up the task manager and force it shut.

Running Eraser after this force quit and exiting with the above method works fine.

I have tested this on being freshly installed and over a reboot.

This is on Windows Vista SP1 Build 6001

Blocking

IdSummaryMilestone
#234Exiting Eraser background process issue.Eraser 6.0

Blocked by

IdSummaryMilestone
#234Exiting Eraser background process issue.Eraser 6.0

Change History

comment:1 Changed 5 years ago by Joel

  • Owner set to Joel
  • Status changed from new to accepted

I'm experiencing it on Windows 7 RC1 x64 as well, but when I break into the Eraser process I don't get any stack traces at all. I'll need to further debug this.

comment:2 Changed 4 years ago by sjw

  • Operating System set to Windows 7
  • Processor Architecture set to i386 (32-bit)

I don't know if you wanted anyone to let you know if they also had this problem, on a different OS version, but I experienced it, too, on Win 7 Pro 32-bit (fresh, full install).

comment:3 Changed 4 years ago by Joel

I've got a fix on r1284 and it seems to work on my W7 x64 so it may be fixed. Go to my profile on the support forum and email me if you want to try a SVN build.

comment:4 Changed 4 years ago by Joel

  • Status changed from accepted to closed
  • Resolution set to fixed

Really fixed in r1304. The bug was right under my nose!

Note: See TracTickets for help on using tickets.