Ticket #282 (closed defect)

Opened 5 years ago

Last modified 5 years ago

Access is Denied

Reported by: GargantulaKon Owned by:
Priority: critical Milestone: Eraser 6.0.7
Component: Core Version: 6.0.6.1376
Keywords: Cc:
Processor Architecture: Blocked By:
Blocking: Operating System: Windows 7

Description

First, I was getting an error that Access is denied to J:\Document and Settings. That folder did not exist on the drive. It used to have a Windows XP installation on it. I tried running as an administrator, but I still ran into issues.

I tried editing the task to change to erase free space since I now formatted (not quick format) the drive to clean it that way. I tried on clicking "Add data" and now I get this error. I tried deleted the task and now when I click "Add Data" I always get this error below. Looks like v6 is not stable yet. I cannot add data even if I click on Continue on the error dialog box.

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

Exception Text
System.UnauthorizedAccessException?: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

at Eraser.Util.VolumeInfo?..ctor(String volumeId)
at Eraser.Util.VolumeInfo?.get_Volumes()
at Eraser.TaskDataSelectionForm?..ctor()
at Eraser.TaskPropertiesForm?.dataAdd_Click(Object sender, EventArgs? e)
at System.Windows.Forms.Control.OnClick?(EventArgs? e)
at System.Windows.Forms.Button.OnMouseUp?(MouseEventArgs? mevent)
at System.Windows.Forms.Control.WmMouseUp?(Message& m, MouseButtons? button, Int32 clicks)
at System.Windows.Forms.Control.WndProc?(Message& m)
at System.Windows.Forms.ButtonBase?.WndProc?(Message& m)
at System.Windows.Forms.Button.WndProc?(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow?.WndProc?(Message& m)
at System.Windows.Forms.NativeWindow?.Callback(IntPtr? hWnd, Int32 msg, IntPtr? wparam, IntPtr? lparam)

Loaded Assemblies
mscorlib

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase?: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll


Eraser

Assembly Version: 6.0.6.1376
Win32 Version: 6.0.6.1376
CodeBase?: file:///C:/Program%20Files/Eraser/Eraser.exe


Eraser.Manager

Assembly Version: 6.0.6.1376
Win32 Version: 6.0.6.1376
CodeBase?: file:///C:/Program%20Files/Eraser/Eraser.Manager.DLL


System.Windows.Forms

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase?: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll


System

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase?: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll


System.Drawing

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase?: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll


Microsoft.VisualBasic?

Assembly Version: 8.0.0.0
Win32 Version: 8.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase?: file:///C:/Windows/assembly/GAC_MSIL/Microsoft.VisualBasic/8.0.0.0__b03f5f7f11d50a3a/Microsoft.VisualBasic.dll


Eraser.Util

Assembly Version: 6.0.6.1376
Win32 Version: 6.0.6.1376
CodeBase?: file:///C:/Program%20Files/Eraser/Eraser.Util.DLL


Eraser.DefaultPlugins?

Assembly Version: 6.0.6.1376
Win32 Version: 6.0.6.1376
CodeBase?: file:///C:/Program%20Files/Eraser/Plugins/Eraser.DefaultPlugins.dll


System.Core

Assembly Version: 3.5.0.0
Win32 Version: 3.5.30729.4926 built by: NetFXw7
CodeBase?: file:///C:/Windows/assembly/GAC_MSIL/System.Core/3.5.0.0__b77a5c561934e089/System.Core.dll


Eraser.resources

Assembly Version: 6.0.6.1376
Win32 Version: 6.0.6.1376
CodeBase?: file:///C:/Program%20Files/Eraser/en/Eraser.resources.DLL


BevelLine?

Assembly Version: 1.0.3589.29437
Win32 Version: 1.0.0.0
CodeBase?: file:///C:/Program%20Files/Eraser/BevelLine.DLL


System.Xml

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase?: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll


Eraser.Manager.resources

Assembly Version: 6.0.6.1376
Win32 Version: 6.0.6.1376
CodeBase?: file:///C:/Program%20Files/Eraser/en/Eraser.Manager.resources.DLL


Accessibility

Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.4927 (NetFXspW7.050727-4900)
CodeBase?: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll


JIT Debugging
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>

<system.windows.forms jitDebugging="true" />

</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.

Blocking

IdSummaryMilestone
#282Access is DeniedEraser 6.0.7

Blocked by

IdSummaryMilestone
#282Access is DeniedEraser 6.0.7

Change History

comment:1 Changed 5 years ago by Joel

  • Status changed from new to pending

When getting an Access Denied error to Documents and Settings what were you doing?

For the Add Data dialog can you list the partitioning of your drives as well as the number of drives? Are you also running Eraser as an administrator? What kind of user account (split token/administrator, administrator, standard user?)

comment:2 Changed 5 years ago by trac-robot

  • Status changed from pending to closed

This ticket was closed automatically by the system. It was previously set to a Pending status and hasn't been updated within 14 days.

Note: See TracTickets for help on using tickets.