Ticket #360 (closed defect)

Opened 4 years ago

Last modified 4 years ago

Eraser crashes and is no longer usable after setting up new task

Reported by: selflove Owned by: Joel
Priority: critical Milestone: Eraser 6.0.8
Component: Core Version: 6.0.7.1893
Keywords: Cc:
Processor Architecture: i386 (32-bit) Blocked By:
Blocking: Operating System: Windows XP

Description

Bug only reproduced once but since it occurred, the program no longer works and crashes whenever the program tries to be launched, therefore I didn't have a chance to try to reproduce the bug yet.

  1. Install Eraser 6.0.7 over 6.0.6.
  2. create a new task called "unused space"
  3. set up the task to remove unused disk space on drive C: using the "default" erasing setting. Leave the task as a manually run one-time task.
  4. click OK to save the task
  5. edit the task that you just created and change the option from manual one-time to weekly and then monthly. I set it to the 28th day of every 1 month. Click OK
  6. The program crashed and I got this error:

See attachments because the Bug Tracking software doesn't let me save the text/Ticket because it thinks it is spam.

Attachments

eraser error.zip (2.1 KB) - added by selflove 4 years ago.
4-27-2010 7-55-15 PM.png (18.7 KB) - added by selflove 4 years ago.
4-27-2010 7-55-25 PM.png (24.2 KB) - added by selflove 4 years ago.
4-27-2010 7-57-21 PM.png (24.2 KB) - added by selflove 4 years ago.
Task List.ersx (2.6 KB) - added by selflove 4 years ago.
8-4-2010 2-11-14 PM.png (12.1 KB) - added by selflove 4 years ago.
error after installing 6.1.0.2241

Change History

Changed 4 years ago by selflove

Changed 4 years ago by selflove

Changed 4 years ago by selflove

Changed 4 years ago by selflove

comment:1 Changed 4 years ago by Joel

  • Status changed from new to accepted
  • Owner set to Joel
  • Component changed from BlackBox to Core
  • Milestone set to Eraser 6.0.8

comment:2 Changed 4 years ago by Joel

Thanks for the ticket, I've reproduced the bug. I'm working on a solution now.

comment:3 Changed 4 years ago by selflove

I uninstalled Eraser and rebooted and then installed Eraser 6.0.7 again, but as soon as the program launches, it crashes with the error like before as shown in the screenshots.

comment:4 Changed 4 years ago by Joel

  • Status changed from accepted to closed
  • Resolution set to fixed

Fixed in r1966-r1967.

For your uninstall/reinstall cycle, you can attach your task list to this ticket (remember that task lists contain logs and other tasks -- which may be sensitive) Otherwise you can email me: http://bbs.heidi.ie/memberlist.php?mode=viewprofile&u=1931

comment:5 Changed 4 years ago by selflove

I only had one task which was the one that I just added as described in the bug. Do you still need me to attach it? Where do I find it after I uninstalled Eraser?

comment:6 Changed 4 years ago by Joel

%LOCALAPPDATA%\Eraser 6\Task List.ersx.

comment:7 Changed 4 years ago by selflove

I searched my hard drive for the file "Task List.ersx" but could not find it; maybe this is because I uninstalled Eraser.

comment:8 Changed 4 years ago by Joel

You do need to enable hidden files and folders, and Show protected operating system files before you can find that file. The file is at that path.

Changed 4 years ago by selflove

comment:9 Changed 4 years ago by selflove

I attached the Task List.ersx file.

comment:10 Changed 4 years ago by Joel

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:11 Changed 4 years ago by Joel

  • Status changed from reopened to pending

Does this still happen with the later nightlies? If not, I'd close this ticket since the bug was fixed earlier.

Changed 4 years ago by selflove

error after installing 6.1.0.2241

comment:12 Changed 4 years ago by selflove

  • Status changed from pending to closed

Attachment (8-4-2010 2-11-14 PM.png) added by ticket reporter.

comment:13 Changed 4 years ago by selflove

Verified closed in 6.1.0.2241, although, when I launched Eraser for the first time after installing 6.1.0.2241, I got a different error message. See screenshot. I only got that message once. After I exited the program and launched it, there are no error messages.

Note: See TracTickets for help on using tickets.