Ticket #433 (assigned defect)

Opened 2 years ago

Last modified 15 months ago

Eraser 6.1.0.2617 crashes upon closing after an erasing job; no report created

Reported by: phkhgh Owned by: Garrett
Priority: critical Milestone: Eraser 6.1/6.2
Component: Core Version:
Keywords: Cc:
Processor Architecture: Blocked By:
Blocking: Operating System: Windows Vista

Description

Several times I've noticed Eraser will crash is close it after an erasing job is completed. Tray pop notification says job is complete. If it is because there are still some Eraser processes "cleaning up" after the "job complete" notice is given, it shouldn't crash - should just delay Eraser's shut down until all processes are through.

When this happens, there is no crash report created, even though black box is installed & enabled & Eraser was restarted after enabling Black Box. So, no crash reports to submit.

It does create crash reports for other types of crashes.

Change History

comment:1 Changed 2 years ago by Joel

  • Component changed from BlackBox to User Interface (UX)
  • Milestone set to Eraser 6.1/6.2

comment:2 Changed 18 months ago by Garrett

This cannot be repeated, does the problem exist with the latest nightly build?

comment:3 Changed 18 months ago by phkhgh

Haven't tried latest nightly. Not sure if there's a way to get notices of new released nightlies? That way, would know about new releases ASAP.

The problem still existed in bld 2804, but only certain instances (don't know why). Build 2804 crashed often. Black box reports were submitted. In another bug I reported, compression of crash reports (even one) still takes extraordinarily long time (in bld 2804), on a fast machine.

AFAIK, can't install a 2 Eraser versions on same machine. It would be useful if this could be done.
If only have 1 machine to use for beta testing & unless valid, critical, reported bugs get fixed in reasonably timely manner, it leaves one w/o a (reliable) working Eraser version.

I had to abandon testing latest nightly 6.1.2804 (& some in the past); at times, crashed so often, it was unusable. Black box reports were submitted. Eraser 6.1(6.2?) didn't seem to be actively developed until few days ago.

Most critical bugs I reported weren't fixed (to make it largely useable), not much point to continue testing - until new nightly is released. Garrett posted the 1st new nightly in many months - a good sign.

comment:4 Changed 16 months ago by Garrett

  • Status changed from new to assigned
  • Owner set to Garrett

Have tried to replicate in latest Bets with no luck. Are you still having the problem?

comment:5 Changed 15 months ago by phkhgh

Yes, still see this issue (sometimes) w/ v6.0.2.2833. It's crashed several times when R clicking tray icon > Exit. No jobs were running. No crash reports were created. Black Box is enabled.

I posted Vista event viewer log in Beta Forum, w/ all the data recorded for the latest crash when closing Eraser.

comment:6 Changed 15 months ago by Joel

  • Priority changed from major to critical
  • Component changed from User Interface (UX) to Core
Note: See TracTickets for help on using tickets.