Ticket #437 (closed defect: worksforme)

Opened 3 years ago

Last modified 3 years ago

Eraser Nightly build 2622 drag & drop not working

Reported by: phkhgh Owned by: Joel
Priority: major Milestone: Eraser 6.1/6.2
Component: User Interface (UX) Version:
Keywords: Cc:
Processor Architecture: Blocked By:
Blocking: Operating System: Windows Vista

Description

In Vista x64.
In previous nightlies, drag & drop to build new tasks was working. Appears to be broken -again- in bld 2622. Can't drag single file or folder to "new task" screen, as in past versions. Tried starting Eraser in Admin & user mode - same result.

Start Eraser in user or admin mode
open Explorer to any non system, non OS folder (Ex. D:\ or E:\)
open new task UI in Eraser
attempt to drag any file or folder to Eraser UI.
Mouse drags the file / folder icon w/ a '+' sign below it, to Eraser UI, as if it is going to add it. Release mouse & file disappears from Eraser UI. Other erasing utilities still work for drag & drop.

Also can't drag / drop files / folders to main task screen. Not sure if this was possible for one time erasing in previous versions, w/o going through creating a new task UI.

Blocking

IdSummaryMilestone
#437Eraser Nightly build 2622 drag & drop not workingEraser 6.1/6.2

Blocked by

IdSummaryMilestone
#437Eraser Nightly build 2622 drag & drop not workingEraser 6.1/6.2

Change History

comment:1 Changed 3 years ago by Joel

  • Owner set to Joel
  • Resolution set to worksforme
  • Status changed from new to closed
  • Component changed from Core to User Interface (UX)
  • Milestone set to Eraser 6.1/6.2

It does matter whether Eraser is started as an administrator or not. If Eraser is started as an administrator, drag and drop will not work. This is because Explorer is running at a lower privilege level than Eraser.

All programs are limited by this. This is not an Eraser problem. Please get back to me if this problem is still present when Eraser is running as a user. I just tested this, it works fine.

Note: See TracTickets for help on using tickets.