admin permission required


New Member
OK, I've read dozens of posts on this topic. I'm the administrator and sole user of my computer. I have right-clicked on Eraser and run it as administrator. I've rebooted and tried everything all over again. Nothing works.
What I am trying to do: erase an external hard drive, used, then formatted so there are no visible files. I want to be sure there are no invisible ones either.
Does anyone know how to do this - apart from the obvious things I've already done?
You didn't say that you closed the running instance of Eraser from the system tray before re-running it as administrator. That's the step that catches most people out.

If you want to completely erase a drive, the procedure with Eraser 6.0 is as follows:
  • quick format the drive;
  • erase free space with eraser, using the procedure you have already followed;
  • to test the erase, run a file recovery program, such as Recuva, to see what it can recover.
If nothing of significance is recoverable, you can reasonably assume that the drive is clean.

You say that 'nothing works', which is fairly inexplicit, but I assume that you from your title are getting an error message about permissions. That will mean that Eraser is not being run as Administrator. You say that you closed the program, and that you rebooted, but neither of those will remove the running process; only right-clicking on the tiny Eraser icon in the system tray and selecting 'Exit Eraser' will do that.

I suspect that also that you are a former XP user who is now using Vista, or more likely Windows 7. In the more recent versions of Windows, accounts with administrative rights run as normal users by default; programs always have to be run explicitly 'as administrator' to gain administrative privileges. The Eraser process cannot run administratively by default, and any attempt to restart it in administrative mode will fail if it is already running. That is why the process must be stopped before running Eraser as Administrator.

Thanks, David. I was explicitly running the program as administrator (except for the first try), and I think the problem was that, oddly, no icon was showing up in the system tray at all, so I didn't know that the program was still running. So in frustration I uninstalled and reinstalled the program and tried again. This time it is working (because I ran the program as administrator from the beginning) - though the system-tray icon disappeared after just a couple of minutes and I have to go to the start menu and click to find out what's going on. I'll bet lots of people who think they've tried everything and are still getting the permission denied error message have the same problem - no icon in system tray, so they think the program is not running. Well, I'm happy it's working now, and I appreciate your help.
Are you in fact running Windows 7? If you are, I may have an even better solution. If you always run Eraser as Administrator, you will lose some functionality (which is why Eraser, unlike many other utilities, does not run administratively by default).

Yes, I'm running Windows 7 x64. And though Eraser ground away for several hours and said it completed the scan, it also said there was an error. I've forgotten the wording and don't have access to it now, but it sounded as if some tag ends of files might still be lurking somewhere on the drive. I decided the drive was probably clean enough and just quit at that point.
Ah. Not letting a free space erase complete makes it pretty much useless, because it's impossible to say (without checking, for example with a file recovery program) whether all the sensitive data has been overwritten or not. Also, the MFT is not cleared until after the free space erase has been completed, so there could be entries relating to sensitive data. Sadly a free space erase will always run for a number of hours, and much longer than that if anything other than single pass erasing (only one pass is needed) is used, or the machine is slow and/or the drive is large. Typically, hard drive performance is the limiting factor.

Particularly on drive C:, there will always be error messages (lots of them, in the log) on a free space erase, particularly on Drive C: if erasing of cluster tips is enabled. Most of these messages are quite unavoidable, because they relate to Windows protected files, and they are therefore, in my opinion, spurious. This is not a bug, because the behaviour is designed, but it is (again in my opinon) a fault, as the user does not need thousands of messages about which she or he can do absolutely nothing. Also, the messages reside in the task list file, taking up space and probably memory when Eraser is running, which makes it a good idea to empty the log for free space erasing tasks.

Going back to the tray icon, Windows seems all to eager to make system tray icons invisible, but they may still be present. If you click on the tiny upwards pointing triangle on the left of the tray, a small window appears with icons that are not visible in the tray. The Eraser icon (which is a miniature version of the desktop icon) may appear here. If it doesn't, click on the 'Customize' link in the window, and you will see options for each icon; for Eraser you will need 'show icon and notifications' to be set. And if the icon is still invisible, open the Eraser program from the desktop and the Start Menu, and the icon should appear.

Thanks DavidHB - closing the running instance of Eraser from the system tray before re-running as administrator solved the problem immediately