Bug report on the latest version( of Eraser


New Member
When double clicking the running erasure task, an error window jumped out. A screenshot with the error window is attached, and the error detail is pasted in this pastebin link:
It's very strange to see this happened, because I have been using Eraser for several years and the version I installed before does not have such problem, the double-clicking worked just fine, showing me a window with detailed process of the running erasure task.


  • double clicking the running erasure task.png
    double clicking the running erasure task.png
    76.8 KB · Views: 2
  • Like
Reactions: mfa


New Member
I have exactly the same problem as “iecsppp”. There is an implied indication in the error message that alglibnet2.dll may be missing or is corrupted, or its caller has processing issues. I checked the system and found that alglibnet2.dll was present in the path: C:\Program Files\Eraser. I am unable to check its integrity.

I also found that Eraser had created a folder named “qSy[R~SlUBTP9V_wb” and placed it in the volume having its Unused Disk Space erased. This folder contained 3,648 files where every file was 221,184 KB, making for a total “Size-on disk” of 769 GB as calculated by the Window Properties wizard. Each of these files had a different name and each name was just as cryptic as the host folder name.

System: Win 7 Home Premium

Version 6.1.7601 Service Pack 1 Build 7601

I repeated the experiment on a Windows 10 machine (fully updated) and exactly the same issues were experienced.

System: Win 10 Home V2004 Build:19041.508

I’m not sure whether the following is relevant in any way, but both machines received Microsoft updates to the .NET frameworks versions 3.5 and 4.8 immediately prior to the installation of Eraser V6.2.0.2990.

V6.2.0.2990 was installed to replace V6.2.0.2982 which had run flawlessly on both the Win 7 and Win 10 machines until an error warning from Windows 7 was received during an “Erase free disk space” session that “Eraser has stopped working”. Note this was just after the .NET updates.


Staff member
Can you download this test version here
Uninstall the current version first and then install this. The version numbers are the same for now.
Let me know if it fixes your issue.


New Member
Hello Muscas. Many thanks for the Beta, and the very fast response. Very professional.

I uninstalled V6.2.0.2982 and Installed Beta as requested.
Ran an erase “Unused disk space” on C:\

The detailed “Erasure Progress” window worked as expected.
The “Hide” function worked correctly.
There were no permanent spurious files placed in the target partition. Although a temporary working folder was seen on C:\
The “Stop” function worked correctly.

I haven't had time to perform a meaningful regression test but the following were observed:
It correctly picked up settings from the previous installation.
Files (both single files and groups of files) erased correctly.
Folders (both single folders and groups of folders) erased correctly.

These tests were all on the Win 10 installation. I will try and run some Win 7 tests later today. I will post those results, good or not so good.
But so far everything is looking very good.

Please let me know if you would like me to run any specific tests.

Great job, and again many thanks.


Staff member
Hi Graham,
That's great to hear. Thank you for your feedback.
Keep safe,
The Eraser Team


New Member
Hi Muscas
FYI - I repeated the "Beta" tests in my previous note on a Win 7 installation and got exactly the same good results.
All my best to the team.



New Member
Eraser has stopped working. Request a file deletion using any method results in ZILCH. I've tried clean reinstalling several times on three devices. Your product has become crap.


New Member
2991 worked perfectly on both Win 7 and Win 10.
Great job - many thanks.
If just 5% of users posted like that it would simply divert attention from the actual, supposed, point of this forum. Support, which appears to be non-existent, for users who find this software won't work on multiple devices.


New Member
Some more items of interest.

In my post of September 29 in the last line, I made reference to V6.2.0.2982 having stopped working. Unfortunately at the time I was too involved with other issues to explore this and simply decided to update to 2900, and subsequently to 2991.

Now after quite a lot of use, V2991 suddenly stopped working on Windows 7 and the operating system generated the following report.

Problem signature:

Problem Event Name: CLR20r3
Problem Signature 01: Eraser.exe
Problem Signature 02:
Problem Signature 03: 5f82dfaf
Problem Signature 04: mscorlib
Problem Signature 05: 4.8.4110.0
Problem Signature 06: 5de6dafa
Problem Signature 07: 1693
Problem Signature 08: f
Problem Signature 09: System.IO.IOException
OS Version: 6.1.7601.
Locale ID: 1033
Additional Information 1: 5a94
Additional Information 2: 5a94d5b75f984d91ff24ed4ebd777557
Additional Information 3: dbda
Additional Information 4: dbda3a323d4792fde02b62c64608689c

Note that the error occurred on a path with a character count of 284. However, excessively long paths have resulted in “completed with error” reports from Eraser in the past. In other words I have evidence to suggest that Eraser can handle long path lengths.

The only other significant difference I am aware of between the conditions under which this failure mode occurred and other error free operations of Eraser is the size of the data block being erased. Typically the block is approximately 200 GB and around 100,000 files.

Since each of these erase runs takes hours to complete (Single pass) I am asking if there are any specific tests you would like me to perform.

System: Win 7 Home Premium
Version 6.1.7601 Service Pack 1 Build 7601
.NET 4.8 KB4503575

I also need to look more closely at Win 10 operations because of an anomaly observed with V 2991 on that environment. In the Win 10 case the Eraser log indicated access to several files was denied because they were in use by another app. No other user controlled apps were running and these were simply backed up Microsoft Office files (.ppt, .docx etc.).

Again please let me know of any targeted and specific tests I can run for you.



New Member
An update to my last post.

In an effort to complete some additional Eraser testing, copies of essentially identical 200 GB backup folders were made on a Win 7 machine. It's important to note that ALL original backups were made on a Win 10 machine and placed on the external backup drive. This same backup drive was connected to the Win 7 machine for the purposes of testing Eraser V 2991 in the Win 7 environment.
Win 7 (and Eraser on the Win 7 machine) were therefore dealing with 200 GB backup folders created entirely in a Win 10 environment.

While attempting to copy these backup folders to produce more test samples on the Win 7 machine, the copy process was halted by Win 7 and a warning issued that 15 files had names too long to be placed in the copy destination folder. These items were "skipped" and the copy process allowed to continue.

Eraser V 2991 was launched via the context menu to erase one of the "test" copies.

The Progress window operated correctly and it is estimated to have run for approximately 6 hours based on information provided in the progress window.

The target folder on the Win 7 machine was later examined and found to be "empty".

Eraser appeared to operate flawlessly in this test.

I draw no conclusions from this other than a much better discipline and awareness on my part is required when operating with multiple operating system environments. Eraser did previously fail however, and it could just be connected with the fact that it was operating under Win 7, but with files and folders (path lengths) put together under a Win 10 environment.

I will look at some additional testing approaches.



New Member
No matter what actions I take on either of two Windows 10 systems - one with the very latest build and one with the earlier build - nothing works to get it to work. This an exerience going back many months after years of successful use. Support here is a joke.