Eraser 6 rc4 875 Windows 7 64 shell extension error


New Member

i have windows 7 64

every time i try erase something from a folder with right click --> eraser- erase menu i get this:

"The Eraser application could not be started. Ensure that your installation of Eraser is not corrupted: try running the Eraser Setup again to Repair the install."

i did that no success i uninstall the entire thing reinstall still nothing always i ge this instead if i use the schedule it works...
right click --> eraser- erase unused space works

also it will be nice to have more status messages cos now i just look at a progress bar in scheduler and thats..all this is minus from v5 where i was able to see the steps that the erase process do.

my guess is that since the eraser.exe need privilege permission to run, the shell task doesn't have access at the process and trow the error. the erase unused space work since it ask for adm rights on execute so it has access to eraser.exe process

thanks for your work in developing this awesome tool!
well i think my guess was true i kill explorer and launch it with administrator rights and then try to erase again and it works so guess this is the issue isn't a way to launch another instance with normal user rights of eraser with the shell context menu? this way avoiding the problem?
fast fix ...make eraser.exe run without administrator rights by unchecking the run as administrator check box in the shortcut properties
of course this will brake the "erase unused space" from shell context menu since eraser no longer run as an administrator.
Eraser Unuse Space will automatically run Eraser elevated without you setting any setting in the Eraser file properties. I wrote code to ensure that Eraser will be launched with elevation in this scenario. The progress activity can be seen by double clicking the currently running task in the scheduler.

If you still get the Can't Find Eraser message try a reinstall again - I am certain it works for me and I am on the exact same platform.

thid is weird then The app install itself an it makes a shortcut on desktop that has run with administrator rights by defalt in this way the erase context menu doesn't work saying cant find the application ...if i turn off the run with administrator rights then when i do erase unused space i get "task completed with errors and if i do the log its say i dont have the required permissions . if i look in task manager il see an instance of eraser.exe when when "erase unused space i see the second instance appearing for 1 sec and then disappear

if i kill the eraser from system try with exit then try to do another erased unused space from the shell menu it works ofc cos it launch eraser with adm rights. and then of i dont kill this instance of eraser if i try to erase a file i get "another instance of eraser is already running with higher privileges then this instance of eraser. Task cannot be added in this manner close the running instance of eraser and start again with administrator privileges or run the command again as an administrator"
I just did a clean install of Eraser, and the desktop shortcut that is created doesn't execute Eraser with administrator rights. Now, by default Eraser doesn't start with administrator rights since you have to give permission for it to do so. Therefore, the running instance will not run with administrator rights by default.

What you need to do is to CLOSE the running copy of Eraser, then go to the explorer window and click Erase Unused Space. That will start a Eraser with administrator privileges. However, once that has been done, Eraser now can no longer "talk" to the running Eraser instance because the processes now use different privileges - one runs as a stand user token, the main application is running as an administrator. Windows Vista (and therefore 7) doesn't let applications with differing tokens from communicating (security issue)

What you're describing is correct behaviour, in other words.

I am struggling with this problem (Eraser 6 and Windows 7). I stop current Eraser program - go to C drive in Windows Explorer - erase unused disc space - and get an immediate completed with errors. What am I doing wrong? Have also tried from desktop icon running with administrative authority.
1. Did you stop the running process?

2. Did you re-start Eraser 'as administrator'?

If those questions make no sense, please read the FAQ post on getting to know Eraser 6.