Eraser 6 stable makes WinXP unusable (unresponsive delays)


New Member
I just upgraded (uninstall old, install new) from Erase 5.8.? to the new 6.0 stable.

The new versions looks nice but it makes WIndows XP totally unusable!
While installation I had a music player running and at that time Eraser 6 started the music started to stutter and stop for several seconds from time to time.
At the same time the Windows UI and all programs become unresponsive.
If I close the GUI and the tray icon everything works again normal. If I start Eraser GUI the problems return.

System: Windows XP Pro on Core2Duo CPU E6600
What display adapter are you using? Is Eraser consuming 100% of one cpu? You can check using task manager.

If so, please do a full memory dump of the Eraser process and email it to me (zipped or better 7-zipped). See for rough guidelines on how to. You'll have to hook up to Eraser.exe and do a .dump.

It's a little difficult, but it's a problem I've not seen in any of the beta builds nor has anyone reported anything similar so I'll need as much info as I can get. Thanks!
Oh, to be precise, you'll need to execute:

.dump /ma C:\Path\To\Dumpfile.dmp

Go to C:\Path\To\Dumpfile.dmp, compress and email it to me. While it may contain sensitive information (it is after all the process snapshot) the information will be kept n the strictest of confidence only for purposes of debugging the problem.

I have had all of the above issues plus it has had issues with the Yahoo Widget Engine too.

Also after I changed the settings Windows XP Pro SP3 32bit tried to launch Dr Watson for many of the background apps I had running which crashed each one.

I can also answer this, my AMD Athlon 64x2 dual core CPU was running at 5 to 10 percent of each core at the time. I was running WinAmp with a Podcast and Opera 10.01 (I am waiting for some free time to backup and install Opera 10.10 as a clean install).

Another behaviour I noticed is that dragging the Eraser Window caused the UI to freeze for a few moments and then resume with the window in its new location.

Finally, Rebooting seems to fix the problem, but I noticed it returning after locking my computer or changing the settings in Eraser.

I will send you an MHT of my computer's spec's and the dump file you are asking for. In brief this is my system:

Asus m2n-e mobo and an Athlon 64x2 4200 Dual Core CPU
4GB DDR2 800MHz RAM with no Swap file.
nvidia 9500 OC video card driving 2 monitors (1280x1024, 1152x864)
Windows XP Pro SP3 fully updated 32 bit
250GB HDD with 2 logical partitions (~110GB each) and an Acronis Safe Zone (Restore Images)
ADSL service 1.5Mb/384Kb unrestricted/unthrottled
Firefox 3.5, Iron, IE8 secondary browsers.
wouldn't you know it, I installed the debugging tools and now its working properly... for now.

I will send it to you when you when it acts up again, however the dump tool is userdump, there is no ".dump" that I could find in the windows debuggers.
When it acts up, could you try unplugging your network interface card, or modem or anything that involves your network and see if it resolves the problem?
will do...

since I added the debugging software I have tried all I can think of but uninstall/reinstall or reinstall 5.x/uninstall 5.x/install 6.x
Have a go at that and see if it helps. Till then I don't believe there's much I can do, sorry.
Well I left my PC on overnight transfering some files and when I logged back in (I lock my computer when I am away from it) there was UI lag where the mouse was freezing on and off.

I logged in and it was worse. I quit Folding@Home hoping that was the culprit, but my cores were just at 50 to 60 percent. I decided to launch WinAmp to see if it was still causing the audio distortion the same way as it was before. Winamp on my system usually takes 1 to 3 seconds to launch even when my machine is busy. It took 3 to 4 minutes to launch and yes it had the same distortion.

I then rebooted my ADSL modem, no change. I cant reseat my NIC because its integrated. To be honest, I can't see how a secure erasure utility would be bothered by that unless its trying to use it in the background and can't. Since Update Checks are manual I can't see why it would be a problem.
Ok, it took a couple of reinstalls and Windbg hanging my computer during boot drive detection (don't ask me how, but I had to leave it off and unplugged before it would boot past the cpu display. as a trained tech, that is really frustrating) I finally got it to attach to a process while Eraser was working find and make a dump.

Now I just have to wait for it to misbehave again.
That's because Eraser queries that system for network information to use as entropy for random data generation. We query he system for things like amount of data transferred etc which are random enough. How about other performance indicators, like hard disk activity? What are they like when Eraser causes the system to lock up?
My networking is bottlenecked through an ancient 10baseT Switch so my PC's integrated nic never hits its Gigabit capabilites, and on some occasions I had most of my ADSL's upload speed was 85-90% utelized but my down was always nil or next to, and most of the time it was happening my upload was next to nothing.

As for my drive, I don't monitor that actively so I will have to break out the utilites and figure that out.

Network activity for RND Data Pools... I had never thought of that. Pooling hard drive caches and traffic I have heard of but never networking data... I am facepalming myself because that is the kind of thing I used to think of when I was programming back in the dark ages before IDEs and Debbugging tools. I still have the occasional nightmare about debugging bianary code I manually entered almost 20 years ago... :roll:

meanwhile I got a dump from Eraser slightly misbehaving and when it was working normally and I will send them to you now... Basicly, instead of the sever skipping of media and delays in in the Windows UI, especially windows repositioning, it just causes media and the odd program to skip once so short it is almost like a set of headphones breaking connection every 20 to 40 seconds. It happens in multiple media players and files. The UI is unaffected.

After I unattached Eraser it closed.