error message re unused disk space


New Member
When I try to erase unused disk space, the task is not completed, and an error message indicates that
"The program does not have the required permissions to erase unused disk space. "
I am using Eraser 6 and Win 7. I am not on a network. Eraser will successfully erase my recycle bin.
Please advise.
I am having the same issue. I have set permission to accept all for all users. The only permission that is grayed out is SPECIAL PERMISSIONS.

Any clue how I can change that permission?

What if I delete all the USERS?

Thanks in advance

I had the exact same problem, everytime I tried to go over the unused dick space that error saying:
Error The program does not have the required permissions to erase the unused space on disk. Run the program as an administrator and retry the operation.

I went to the properties of the shortcut to Eraser and set it to run as administrator, did nothing, then tried the security Tab of same properties, click EDIT button and set all except "Everyone" to Full control and then it worked fine, But you must make sure that Eraser is not running, usually it still runs in systray. Then start it with shortcut....
The issue is most likely to be because an instance of Eraser was running already without administrative privileges in the 1st place.

Eraser starts automatically (without these privileges) when windows starts up so you'll need to exit this first, "unprivileged" instance before any of your administrative changes will have any effect.

Right click on the systray icon --> select Exit Eraser --> Right click the eraser desktop or start menu icon to launch --> select Run as Administrator (if you haven't already set it to run as an administrator), and you should now be able to run the unused disk space task.

I've had this problem on numerous occasions in the past, and worryingly each time I forget about this simple solution! I would try this 1st before changing the specific user settings.