Failed To Allocate Data Buffer (out of memory).


New Member
Here is the Erasing Report error in its entirety:

Failed to allocate data buffer (out of memory). Try closing other applications or restarting windows.

This error occurred after I had finished using the right-click context menu with the new v5.84 x32 Eraser to securely one-pass erase about 3,000 files using Explorer's search function on 28 subfolders while limiting the number of files erased to less than 600 at a time. I also encountered the same error using v5.6 about six months ago. But soon afterward, other problems with v5.6 prevented the same error from recurring. I tried disk cleanup on the temporary file folder this time and that didn't fix the problem. I still had 11 GB free so free space wasn't the problem either. I do want to emphasize, however, that I am pleased with 99% of the new version's functionality.
I tried booting Windows XP Home into safe mode, searching the same 28 sub-folders using Explorer, and erasing several thousand files of size less than or equal to 10 KB, selecting 600 files at a time. The first sign of trouble was when "Erase" disappeared from the right-click context menu. Then I tried selecting only ten files and the "Erase" option reappeared. But when I attempted to erase them, the Eraser "out of memory" error popped up. I believe the recurrence of the problem in safe mode indicates that this problem does, in fact, constitute a minor Eraser bug.