Fails to start after install Win 7x64


New Member
I initially installed Eraser on my new laptop running Win7x64. It would occasionally just shut down, not even using it. Then, yesterday, I started to wipe some folders, realized they were the wrong ones, and tried to stop the process. No response from Eraser, not even sure it had actually started erasing them yet. Anyway, I forced windows to shut down and restarted. After that Eraser would crash when trying to start it.

I have uninstalled and reinstalled serveral times. I have cleaned the registry each time as suggested in other posts. I have tried installing 6.08.2273 several times after uninstall and registry cleanup. I have tried several different compatibility modes and run as administrator (even though my user is an administrator). I have disabled UAC, same result no matter what I try.

Eraser seems to install without any apparent error, but immediately crashes when trying to run it "Eraser has stopped working".

What else can I try? (Windows error information below.)


Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: eraser.exe
Problem Signature 02:
Problem Signature 03: 4cd2be16
Problem Signature 04: mscorlib
Problem Signature 05:
Problem Signature 06: 4bebe8e2
Problem Signature 07: 47a7
Problem Signature 08: 85
Problem Signature 09: System.IO.FileLoadException
OS Version: 6.1.7600.
Locale ID: 1033
One more odd thing just happened. Eraser was not running, but I decided to right click on a file and chose eraser to test it that way. First, I got the error posted about, but then got this error.

Eraser Shell Extension. Eraser cannot connect to the running instance for erasures.

Not sure how this fits in to the problem.

To take your second point first, Eraser cannot connect to the running instance, because it has shut down (= crashed). So, most likely, your second problem is a function of the first.

The commonest cause of odd Eraser crashes is a corrupt Task list; you need to delete the file %LOCALAPPDATA%\Eraser 6\Task List .ersx, then re-start Eraser. In case you have not met the environment variable %LOCALAPPDATA% before, just type it into the Run box, select OK, and an Explorer window will open in the correct folder.

Another thing to do is run the disk checker; I find that (not surprisingly) Eraser can be sensitive to errors in the file system.

Yes, please try to remove the task list and see if it resolves the crash. Please report back; if that's solved we can help to resolve your other issues.
I have uninstalled eraser 6.1 and installed 6.8 but now the blumin thing won't erase the recycle bim or any files, it's most frustrating when I installed 6.8 it ran once and only once it will now do what the last version would not that's erase clusters, but the old eraser at least erased whatever i asked it to do, Any ideas on what my next step should be, or does anyone have some form of patch to fix this most annoying bloody problem????????????? oilpainter. :-((((((((((((((((((((((((( :?
Please be specific. Describe step by step what is happening and what goes wrong. Your use of the words "erase clusters" suggests that you do not fully understand what the program is, or should be, doing. We in turn need to understand your problem if we are to help you.