Strange big files created after disk space delete


New Member
Tonight, before bed, I activate an erase unused disk space in my three partitions with Gutmann 35 passes.

Today I found in F: a folder named "hRh8 Npr85xF{HYgzy" with 96 files of similar names (cjuih~KlyQBvxWjV{0", "jn8Ua[O5I3U[cfP9W0", etc) of 216 MB each. Total 20.2 GB.

Eraser was all that was active on the computer, so I guess that was it. I've seen the "Windows Event Log" and the computer was restarted at 2:04, the same time that these files were created.

I found a Eraser' log with files that could not be erased by having long routes, issue already solved today with the Long Path Tool program.

Well, do you know the reason of this? Can I delete the files?

Thank you
Ditto, same here.

I performed an "Erase Unused Space" operation on a 500 GB drive with NTFS on it overnight and in the morning there was a new folder called "earDQqbI[Gj[dl)ijgep7cfET9t[OzI," in the root directory containing over 35,000+ files all with random names ... Eraser is clearly messing with some important part of the file system (MFT$ ??) and I'm thinking this can't be good! A check of the Event Viewer does not show any computer restarts or any serious errors.

Also, when I logged onto the Windows 7 Ultimate x64 machine the Erasure Progress dialog box was appearing and then immediately disappearing (created and destroyed?) while moving in a diagonal line from top-left of screen to bottom-right of screen. When I pressed PrintScreen to try and capture a screenshot the madness ended...

If it helps I was using a custom erasure method consisting of 3 passes:
1. Hex 01
2. Random
3. Hex 00

If you require any further information please do not hesistate to contact me via the email address that I used to register with the forum.

I know this happened in an older version because it used a character in the randomly generated names that Windows didn't like, so when it would go back to delete all the files it created when wiping, it would fail or hang (it's been a while can't remember exactly) but I believe they took that illegal character out of the possible characters to eliminate that as the cause.

I still had a similar problem to you guys, but only after I upgraded my hard drive to one that had a HUGE amount of free space. I think either Eraser is dying/hanging as it's going back to delete all those files and leaving them. What I end up doing is just killing eraser.exe in task manager, then do a rmdir /s /q FolderName to get rid of the folder, but fair warning it will take hours upon hours, and after it runs for a bit, performance of your machine will be horrible. I end up letting it run for like a half hour, then do a ctrl+c to cancel, then do the rmdir again, until it finally goes away. or i just let the rmdir run overnight when i don't need the PC for quite a while.
The Long Path Tool is also useful in situations where you see these error messages: Cannot read from source file or disk, there has been a sharing violation, cannot delete file or folder, the file name you specified is not valid or too long, the source or destination file may be in use and many other file managing errors that you encounter in your computing use.
This will help you sure.
Re: destination path too long

Please try longpathtool and get the solution of above relevant issue.It was really helped me to get the right solution which worked for me.