Unable to erase large USB external drives


New Member
I have several large USB external drives I am trying to erase and so far every single attempt has ended with errors. The drives are 1 to 2 TB drives, USB 2.0. I run Eraser as administrator. Judging from the speed of the progress bar, I expect it to take over a week to run this, but the longest I've been able to keep it running is about a day and a half. Eraser suddenly stops with the status "Completed with errors", and the log says "The specified network resource or device is no longer available."

It would be nice if Eraser could pick up where it left off, but I presume there's some power setting or something that will keep the drive active until the erasure is complete? Or is there some other way I should go about wiping these drives?

Thanks in advance.
I think you have some kind of system problem. What hardware, OS version, and version of Eraser are you using? Have you tried using different USB ports? If you are using a laptop, how are the external drives powered?

I've actually tried this on three different systems. All Windows 7 64 bit, Eraser 6. The hard drives all have a power adapter. I have tried using different USB ports. One of the drives I am trying to erase does have power issues (which is why I want to get rid of it), but the others work fine.
My suspicion is that the drives are going into a standby mode that causes Eraser to fail, but I don't know how to test that idea yet.
Currently what I'm trying to do is fill the drive with a bazillion copies of a 3 GB ISO file, and then I should be able use Eraser to erase those files, thus accomplishing the same goal. This could take me a while! In the movies massive hard drives are wiped in seconds! :)
If the drive gives up on Windows (and Eraser), chances are the disk would still retain the information used for erasure. If you are REALLY desperate (and if you are using a one-pass erasure method), running another unused space task would accomplish the same effect as continuing where it left off. Of course, this may not be as clean, though logically it does the same thing (all bets are off when hardware doesn't behave as it's supposed to, you know?)
I gave that a shot, continuing the unused space erasing, but Eraser would error out because the directory structure was corrupted, I assume due to the USB disconnection. Having Windows try to fix the directory table didn't really help. But you are absolutely right, there's not a whole lot that can be done if the hardware doesn't behave. Maybe it's time for a hardware solution... a 10 pound sledge should be sufficient... and more fun!

Thanks for all the help and ideas!
Sometimes the sledge hammer option is all we have left :) , but not necessarily in this case ...

If a corrupt file table is at the root of any of your problems (i.e. the corruption is not caused by any hardware problem which is still present), then formatting the drive (or, if you want to be really thorough, deleting the partition and creating a new one) before you run the free space erase may help.

Your idea of using large files as 'ballast' files is a useful one; it is an old idea but one we hear less about these days, and it is good to be reminded of it. What you can do is copy as many ballast files as possible to the drive, and then use the free space erase to deal with the last bit of free space and the MFT. Assuming that the ballast files contain no sensitive data, they are of course as good as erasing files from the user perspective.

May i suggest as stated above, since you already have over written your drives with iso's that you 1st try reformatting those drives using the Windows Drive Management.

Control Panel\All Control Panel Items\Administrative Tools\Computer Management\Disk Management

Then you can also try DBAN = Darik's Boot And Nuke
http://www.dban.org/download/ to securely wipe those drives.

I'd advise against using DBAN on any machine on which you wish to retain anything. Also, it may not work as it has not been updated or supported for a long time. If there really is a hardware of drive/partition issue, DBAN is unlikely to help. It is best to get to the root of why this drive plays up; in tricky cases, removing and re-creating the partition often fixes the problem