[bug] Disabling Eraser on Startup

cee12

New Member
With the latest release (6.0.8 ) have disabled Eraser in the startup tab of MSConfig, but Eraser continues to load and show a tray icon on reboot.
Uninstalled and reinstalled 6.0.8, but the issue still occurs. I'm using Win7 64bit.

Cheers
 

Joel

Active Member
Reinstalling will cause Eraser to start up again automatically, the installer creates the start up entry. You'll have to disable Eraser's start up again.

If that still doesn't work, you'll have to manually check the HKLM\Software\Microsoft\Windows\CurrentVersion\Run key for Eraser's start up entry.
 

cee12

New Member
Reinstalling will cause Eraser to start up again automatically, the installer creates the start up entry. You'll have to disable Eraser's start up again.
The startup entry is disabled. I uninstalled/reinstalled and disabled the startup to see if a clean version would fix the issue, it didn't. As a clean install didn't fix the issue for me I'm guessing this is a (minor) programming bug that affects more then just my pc.

If that still doesn't work, you'll have to manually check the HKLM\Software\Microsoft\Windows\CurrentVersion\Run key for Eraser's start up entry.
I've never really played around with the reg, so I don't know what i am looking at. This is the content of said file, I can't see any reference to an eraser file:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run]
"Setwallpaper"="c:\\programdata\\SetWallpaper.cmd"
"SynAsusAcpi"=hex(2):25,00,50,00,72,00,6f,00,67,00,72,00,61,00,6d,00,46,00,69,\
00,6c,00,65,00,73,00,25,00,5c,00,53,00,79,00,6e,00,61,00,70,00,74,00,69,00,\
63,00,73,00,5c,00,53,00,79,00,6e,00,54,00,50,00,5c,00,53,00,79,00,6e,00,41,\
00,73,00,75,00,73,00,41,00,63,00,70,00,69,00,2e,00,65,00,78,00,65,00,00,00
"SynTPEnh"=hex(2):25,00,50,00,72,00,6f,00,67,00,72,00,61,00,6d,00,46,00,69,00,\
6c,00,65,00,73,00,25,00,5c,00,53,00,79,00,6e,00,61,00,70,00,74,00,69,00,63,\
00,73,00,5c,00,53,00,79,00,6e,00,54,00,50,00,5c,00,53,00,79,00,6e,00,54,00,\
50,00,45,00,6e,00,68,00,2e,00,65,00,78,00,65,00,00,00
"IgfxTray"="C:\\Windows\\system32\\igfxtray.exe"
"HotKeysCmds"="C:\\Windows\\system32\\hkcmd.exe"
"Persistence"="C:\\Windows\\system32\\igfxpers.exe"
 

Joel

Active Member
It's not in the registry -- then the culprit is somewhere else. Did you check the Startup folder in your start menu? Are there other user accounts on your computer that people log on to; if so, does Eraser also start automatically for them?

Eraser 6 proper does not insert its own start up entries into Windows. Eraser 5 did it, however. Did you have Eraser 5 installed on this computer at any point in time?
 

cee12

New Member
No I never had version 5, v6.0.8 is the first and only version I've installed.

There isn't an icon in the startup folder, and the other account (a guest account) has never been used, so there wouldn't be one in that either.
 

Joel

Active Member
How about the registry key HKCU\Software\Microsoft\Windows\CurrentVersion\Run? Can you do a dump like the previous one?

If you log into the Guest Account, and Eraser does not start, most certainly the key is in the HKCU key instead. Though, I do not know why there should be an entry in HKCU, Eraser does not reference that.
 

cee12

New Member
I logged into the guest account, and eraser didn't start up. But it doesn't look like there is an entry for HKCU either:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run]
"Power2GoExpress"="NA"
"AdobeBridge"=""
"PeerBlock"="C:\\Program Files\\PeerBlock\\peerblock.exe"
"TouchFreeze"="C:\\Program Files (x86)\\TouchFreeze\\TouchFreeze.exe"
"Google Update"="\"C:\\Users\\Chris\\AppData\\Local\\Google\\Update\\GoogleUpdate.exe\" /c"
"AlarmWiz"="C:\\Program Files (x86)\\AlarmWiz\\alarmwiz.exe startup"
"NortonUpdateAgent"="C:\\ProgramData\\Norton\\NUA.exe"
 

Joel

Active Member
You may have to use a tool like Autoruns to disable it, I'm out of ideas... The behaviour is indeed very strange.
 

phila

New Member
I just installed 6.0.8.2273 to try it out, and have never installed any version of eraser before. Eraser started automatically and there appears to be nothing in the settings tab to prevent that. I know I can, presumably, turn this off via msconfig, but I'm surprised that such a well thought out program does not have a startup option to allow the user this choice from its claimed user friendly interface. Or am I missing something?
 

Joel

Active Member
You can set it and forget it... the design decisions behind this has been explained at great length in this post so I won't repeat myself here.
 

phila

New Member
Quite possibly, but I (the friendly user) do not WANT to have it running at present. I downloaded and installed it with a view to evaluating it at some point, but I do NOT want it running now. Why should YOU think you know better than me about MY computer?
 
Top