Difficulty trying to erase unused space on c drive

simon1

New Member
I have a Dell inspron 1525 laptop, with Windows Vista and im having dificulty trying to erase unused space on the c drive. Ive been able to set up the task on the Erase shedule, but when I have tried to run it either manually of after a restart, the action seems to fail with the following error message :

Session: 30 January 2010 17:09:15
30 January 2010 17:09:15
Error The program does not have the required permissions to erase the unused space on disk. Run the program as an administrator and retry the operation

However I have been successful using erase with my rescyling bin, so cant really undrstand it doesnt seem to let me on my unused space. I am also on my pc as the administrator, I think?

heres hoping, Simon1 :?:

ps. I'm no computer boffin guys, so bare with me.
 

DavidHB

Active Member
Windows thinks that erasing the space on your system drive is a dangerous process, which it isn't; in fact, by its nature, it's less dangerous than erasing the contents of the Recycle Bin. It's a bit stupid but we have to live with it.

Vista and now Windows 7 operate in such a way that users with administrative privileges don't get to use them unless they ask nicely first. In the present case, what you do is right-click on the Eraser icon on your desktop, and, from the menu that appears, select 'Run as administrator'. That should fix your problem.

Hope this helps.

David
 

Joel

Active Member
Hmm, before you start the new instance of Eraser, exit the one that's already running first (in the system notification area aka tray)
 

DavidHB

Active Member
Joel said:
Hmm, before you start the new instance of Eraser, exit the one that's already running first (in the system notification area aka tray)
Yes, forgot this, as it doesn't apply to me; I have unticked the setting to start the Eraser scheduler in the taskbar. Vista tends to block Eraser startup in any case, and I don't need the functionality. So Joel's point applies only if you do have a running instance of Eraser, which is the default.

David
 

simon1

New Member
I have followed the advice about right clicking to active the administrator function, but still didnt work, I have also deleted the original shedule tasks that i set up in the Erase Schedule, however im unsure whether I have understood your advice really in terms of where to navigate to, mainly as I dont really undertsand some of the language you use guys:

"before you start the new instance of Eraser, exit the one that's already running first (in the system notification area aka tray" and

"I have unticked the setting to start the Eraser scheduler in the taskbar. Vista tends to block Eraser startup in any case, and I don't need the functionality. So Joel's point applies only if you do have a running instance of Eraser, which is the default."

are these tasks i need to action on the actual Erase Schedule under the schedule and settings tabs, or should i be going somewhare else on my pc to action these.

heres hoping simon1
 

DavidHB

Active Member
simon1 said:
I have followed the advice about right clicking to active the administrator function, but still didn't work, I have also deleted the original schedule tasks that i set up in the Erase Schedule, however I'm unsure whether I have understood your advice really in terms of where to navigate to, mainly as I don't really understand some of the language you use guys:
Just, so's you know: this is not Joel's and my geek-speak, this is official Windows geek-speak. Trouble is, there is no plain language translation which is sufficiently precise to make the point in a few words.

Joel said:
before you start the new instance of Eraser, exit the one that's already running first (in the system notification area aka tray).
An instance is a program that's running, in a window, in the background, or both. Some applications (like Eraser, or Windows Explorer) can have more than one instance running at once; others can't. Joel's point is that if Eraser is already running in the background, it can't be started in another instance with administrative privileges. So, at the right hand end of your taskbar at the bottom of the screen, look among the collection of little icons around the clock (you may have to expand it temporarily by clicking on the tiny left-pointing arrowhead), and see if you can find an Eraser icon. If you do, there is an instance of Eraser running; right-click on the icon, and select 'Exit'. Now you can start your new instance of Eraser with administrative privileges as previously described.

DavidHB said:
I have unticked the setting to start the Eraser scheduler in the taskbar. Vista tends to block Eraser startup in any case, and I don't need the functionality. So Joel's point applies only if you do have a running instance of Eraser, which is the default.
With Eraser 5, the main reason for having the program running in the background is the scheduler. By default, eraser starts up with Windows. My Windows Vista installation doesn't like this, blocks it, and tells me so. For me, this is not a problem, as I don't use the scheduler. All I did was untick the Option in Eraser preferences to have Eraser start with Windows, and the Windows annoyance went away. If I'd needed the scheduler, things would have been more complicated. As it was, because I don't use it, I forgot to mention the need to close the running instance (which most people will have) before running Eraser as administrator, and Joel rectified the omission.

Hope that explains things.

David
 

Joel

Active Member
Actually, Simon's using v6 so there will always be a (non-elevated/non-administrator) instance of Eraser running all the time.
 

DavidHB

Active Member
Joel said:
Actually, Simon's using v6 so there will always be a (non-elevated/non-administrator) instance of Eraser running all the time.
So he is. One of my senior moments; my mind was in the wrong thread ...

The advice is the same, however. Hope it helps.

David
 

bill735

New Member
Hi again. My post on another thread had the same problem with v.5. After I got the hint from David, I figured it out after some fiddling . Yes v.5 works fine now under Win7 except for the annoyance of having to run eraser as an administrator (I don't have an Icon so I right click in start menu), create a task, and then run it to erase the unused space. Be prepared for it to take a looooooong time to finish. I have also disabled the run at startup so I'm not tempted to use eraser from Windows Explorer which doesn't seem to trigger running as an administrator even if the system tray was started using run as administrator. Sorry about the double speak but as was stated earlier its caused by MS protecting me from myself (a difficult task). Now :)
 

DavidHB

Active Member
bill735 said:
... v.5 works fine now under Win7 except for the annoyance of having to run eraser as an administrator (I don't have an Icon).
You can also change the properties of Eraser.exe in the install folder, to get the same result without having to specify it every time.

bill735 said:
I right click in start menu), create a task, and then run it to erase the unused space. Be prepared for it to take a looooooong time to finish.
Indeed. It reminds us how big and (relatively) slow today's hard drives are. You'd have to have particular reasons for running erase free space in anything but the default single pass mode. File/folder erasing is often much quicker, even with multiple passes; there's a lot less ground to cover.

bill735 said:
I have also disabled the run at startup so I'm not tempted to use eraser from Windows Explorer which doesn't seem to trigger running as an administrator even if the system tray was started using run as administrator.
You don't need to run 'elevated' for everything that Eraser does; normal file/folder erasing (depending on which files and folders, of course) usually works without elevation. But if you're running elevated in any case, that's not an issue, and you can freely use the context menu. That said, I can't use run at startup: Vista doesn't like it for some reason. Eraser 6 works differently; it always needs to run at startup, but it seems (after a few initial arguments) to co-exist quite happily with Windows 7.

Hope this helps,

David
 
Top