Eraser Causes freeze of XP when right clicking

Joel

Active Member
The bug has been fixed in trunk (well, technically not fixed by me -- I just upgraded the runtime Eraser links with, the problem was not with Eraser code anyway.)

Joel
 

Argodon

New Member
I also started the same problem after reinstalling Windows and install some programs.
Long time could understand because of what is happening, Then I discovered a conflict applications Avast 4.8 & Eraser 5.8.7.
Errors began to appear in Windows XP SP3 with Avast after add(install) Eraser.
Earlier, before reinstall Windows was installed eraser 5.8.6 and this error was not.
But the old version Eraser I could not find(.

I know that when installing Eraser, also installed MS Visual C++ 2008 9.0.30729.17. Then tried to remove it, and voila problem has been resolved, but without VC Runtimes Eraser does not work, grrr.
OK, I found and installed MS Visual C++ 2008 9.0.21022.8. and it worked!

Later, when I was searching for a description of the problem, found this forum and learned that I was not the first who discovered the unusual solution :lol:

sorry for bad English.
 

pIIrash

New Member
Steps:

After Freezing:
Start Task Manager:
Find explorer.exe in Processes
Stop it!
In Task Manager File / Run:
explorer.exe ... ENTER
Right click on Recycle bin again and enjoy it! :)
Sometimes it's not enough do at first.

Sorry for my English. :roll:
 

Jubei

New Member
pIIrash said:
Steps:

After Freezing:
Start Task Manager:
Find explorer.exe in Processes
Stop it!
In Task Manager File / Run:
explorer.exe ... ENTER
Right click on Recycle bin again and enjoy it! :)
Sometimes it's not enough do at first.

Sorry for my English. :roll:

Hi, i knew that thing with the restarting explorer.exe.. but do you want to do that every Windows session..?
i am not.. ;)
I use the same method one post above.. deinstalling the MS Visual C++ packet that comes with eraser and install the new MS Visual C++ 2008 9.0.21022.8.. now, the right-click freezing problem is gone..
 

streyy

New Member
FWIW I have had to give up and remove eraser because of this problem, no matter whose problem it is. It certainly began for me after switching from a commercial av to avast. No combination/version of the MS C++ redistributable pkg that I could find, worked with it. 5.8.7 and 6 rc5 both do it.

In addition I could not erase free space with cluster tips on 6 rc5; it would terminate on an access denied error without giving me a pathname (last normal complaint was about a file in WinSxS but the ending error message gave no filename.

I've read through the forum and tried everything I found about both of these problems. Eventually I went back to 5.8.7 to erase the cluster tips and restarted explorer when it hung (at the 1st right-click after every reboot). Since I can't hand this box over to multiple users in that state, eraser had to go. I hope the context-triggered hang gets fully resolved at some point; eraser is terrific and I've depended on it for years. Thanks for working on it.
 

Joel

Active Member
Users can try the latest builds of Eraser available on the Nightly builds page and that should not have the associated problem. Uninstall all Visual C++ runtimes before proceeding.
 

HMonk

New Member
FYI

I recently DLed and installed eraser in a dual boot XP/Win7 system. I have no issues with Win7. However, in XP right clicking on any file, in any window (e.g., explorer, desktop) causes XP to freeze. If the right click is within explorer, then the freeze is cleared via task manager; elsewhere - and I have to reboot. I was able to isolate the shell extension conflicts using ShellExView which can be found at:
http://www.nirsoft.net/utils/shexview.html. To use this app, one simply disables shell extensions (in batches if there are many) until the offending extension(s) is located.

I'll keep an eye out for updates that eliminate this issue.

Monk
 

Joel

Active Member
You can always try the nightly builds. They should not have the problems mentioned here.
 

Joel

Active Member
Eraser 5.8.8 and 6.0.6 uses the new runtimes which do not cause this problem.
 

HMonk

New Member
Thank you Joel.

I installed v. 6.0.6 and all is well.

Monk
 
Top