Erasing Free Space with DOS commands.

phibins

New Member
I cannot find anywhere in the help guide a reference to some of the DOS commands i can use to call on ERASER.

Are some commands available to erase free space?

Thanks.
PR
 

DavidHB

Active Member
If you mean does Eraser have a command line interface, yes, it does. For details, enter 'eraser help' in the Run box.

David
 

phibins

New Member
Thanks for your help AGAIN David.

This is what i typed into RUN,
Code:
Eraser addtask -q [-m<45671da4-9401-46e4-9c0d-89b94e89c8b5>][-s=(now)](-u=<P:\[,clusterTips])

it said "
Code:
 unknown argument [-m<45671da4-9401-46e4-9c0d-89b94e89c8b5>][-s=(now)](-u=<P:\[,clusterTips])
"

What was my error????
 

DavidHB

Active Member
phibins said:
What was my error????
Sorry, the CLI teases my small brain too much for me to use it :( This is one for Joel, when his exam. preparations allow him a little time to post.

David
 

phibins

New Member
Thanks for the reply.

Just for other people reading this thread i figured out that all brackets should be removed (which isn't always the case in DOS command lines). and that i was missing an equal sign.

it should look something like this

Code:
Eraser addtask -m=45671da4-9401-46e4-9c0d-89b94e89c8b5 -s=now -u=<P:\ ,clusterTips
Except, this still doesn't work, and returns:

Code:
Unknown argument: ,clusterTips
Hopefully Joel can help me when he has time,

Thanks again!

BTW
 

DavidHB

Active Member
The previous health warning about my small brain applies. But, if I read the instructions correctly, round brackets round the arguments are needed. Also, you specified the root folder of the drive (P:\) rather than the drive as such (P:), and you added a spurious '<' in front of the drive letter.

Thus, I would amend your

Eraser addtask -m=45671da4-9401-46e4-9c0d-89b94e89c8b5 -s=now -u=<P:\ ,clusterTips

to read

Eraser addtask -m=(45671da4-9401-46e4-9c0d-89b94e89c8b5) -s=(now) -u=P:,clusterTips=(true)

But I can't test this, so I have no idea whether it works. You will certainly need to run it from an elevated command prompt (and probably kill the running Eraser process first).

David
 

phibins

New Member
Thanks again for the reply david,

The command line definitally wants the round brackets. and how did you know to put
Code:
,clusterTips=(true)
since it doesn't say anything in the 'eraser help'.

Anyway, thanks to that I managed to get it to work like this:

Code:
Eraser addtask -m=45671da4-9401-46e4-9c0d-89b94e89c8b5 -s=now -u=P:,clusterTips=(true)

Also, in what forum do i make suggestions for eraser????
 

Joel

Active Member
...I chuckle reading this thread. This is testament to why I say the command line is not meant for mortals like us to use. :D It's currently only used by the Eraser shell extension, thus the command line interface is easy for a computer to generate and parse... but nearly impossible for humans to read.

Yes, your conclusion at the end of the search was correct, no need for brackets etc. The help screen used those to demarcate option types. Traditionally, <option> was used to refer to mandatory arguments and [option] used to refer to optional arguments, which probably caused your confusion. I apologise for not making the CLI more accessible... I'll try to make it better for 6.2.
 

DavidHB

Active Member
Joel said:
I apologise for not making the CLI more accessible... I'll try to make it better for 6.2.
But it's not a top priority in my book, for the reasons Joel gives. Not like stopping the log from generating thousands of entries on a free space erase ...

David
 

sonnia

New Member
Hello,
I am runing the following command line and get the error below.

Code:
    eraser addtask -m=(d1583631-702e-4dbf-a0e9-c35dba481702) -s=now -d=c:\temp\
I am guessing I got the path wrong. Can someone point out my error?

Session: Friday, September 16, 2011 5:07:59 PM
Friday, September 16, 2011 5:07:59 PM Error Value cannot be null.
Parameter name: path

This one without the "\" at the end give me the error below.
Code:
 eraser addtask -m=(d1583631-702e-4dbf-a0e9-c35dba481702) -s=now -d=c:\temp
Session: Friday, September 16, 2011 5:13:55 PM
Friday, September 16, 2011 5:13:55 PM Error Attempted to access a path that is not on the disk.

Looking at the GUI, looks like its trying to target c:\program files\eraser\temp
Why is it virtualizing the path? How do I direct it to C:\temp from the command line?
 

Joel

Active Member
Try -d=C:\\Temp\\
 
Top