I cannot get some files to delete with eraser...

muxman

New Member
When I try to delete a file in XP with eraser it won't delete. I get an error saying this:

Code:
Failed: E:\info.txt (The process cannot access the file because it is being used by another process.)
There is nothing open accessing the file. If I just delete it without eraser it works just fine and goes into the recycle bin. It's doing this when ever I try to erase a single file. When I try to erase multiple files it works just fine, but not single files. I don't always have multiple files to erase so that's not always an option.

Any ideas on how to fix this?
 

Joel

Active Member
How are you able to ascertain that the file really is not open by other programs? Did you use process explorer or Handle?

Joel
 

muxman

New Member
I checked all the open processes on the computer and there is no text editor open. I've even rebooted the computer and the very first thing I've done is open explorer and try to erase the text file, not opening it with anything, just erasing it so that no other program would or should be accessing a text file.

It's also not just this file, it can be any file on the computer. It will give this same error. Every file on the computer can't possibly have something accesses it all the time. The files can be moved with no error and even deleted with standard recycle bin. If the file was being accessed moving it should generate an error as well, which it doesn't.
 

muxman

New Member
Also, I can even create a brand new file by right clicking, go to new and pick any file type. Then immediately try to erase it without ever opening it with anything. I'll get the same error.
 

Joel

Active Member
See the support guildelines in the forum on how to use Handle.

Also this seems to be a anti-virus/firewall/computer security issue where the program is scanning the file. Are you able to share with us what apps you use for the abovementioned tasks?

Joel
 

muxman

New Member
Joel said:
See the support guildelines in the forum on how to use Handle.

Also this seems to be a anti-virus/firewall/computer security issue where the program is scanning the file. Are you able to share with us what apps you use for the abovementioned tasks?

Joel

That sounds good but I have another computer running the exact same software. The same version of the OS, AV, firewall and version of eraser and it's never had this issue. While this computer is having it.

I'm using XP with the firewall built in and AVG antivirus. I've tried turning these items on and off and there's no difference in the problem. I've uninstalled the AV software and tried it without AV and the same. Then reinstalled my AV software and no change.

I've even gone into the file permissions and set the file to everyone has full access to that file and no change. I've made sure I'm the owner of the file and I have full access to the file and the directory it's in with no change.

If I try to erase the file and it doesn't work, I can make a copy of that file right next to it, erase both files at once and it works everytime. But trying to erase a single file by itself is when I get that error. It's not all the time. One time the file may erase and the next file I do singly won't work. I don't see any pattern to it, it just seems random.
 
Top