Installing Eraser 6.0.8 over Eraser 6.0.7

Status
Not open for further replies.

DavidHB

Active Member
Following the release of Eraser 6.0.8. a few days ago, it has been found that (in the release build at least), it will not install directly over Version 6.0.7, but produces the error message

"A newer version of Eraser is already installed. Setup will now exit".

Joel has traced the problem to the WiX install file builder, which does not treat the thousands digit in the build number as significant (!).

Until this problem is fixed, the workaround is to uninstall the older version before installing the newer one. If the new version then refuses to start, delete the file Task List.ersx (as described in more detail in the FAQ on Common Erser problems) before trying to run Eraser again.

David
 

Joel

Active Member
More investigation has shown that the minor version component is not included in the version compare. A fix should be out soon (but no ETA as yet)
 
Status
Not open for further replies.
Top