Problems to install Eraser 6.07.1893

FloP

New Member
I downloaded th installation file of Eraser 6.0.7.1893. At the point where the installation procedure tries to download .NET Framework 3.5 SP1 I can agree to the license agreement and see the download progress window. Status changes from initializing to calculating transmission rate. But there is no progress. Nothing is downloaded. Abord of download leads to abord of installation. Loading .NET Framework 3.5 SP1 from Microsoft web-page has the same effect.
I downloaded .NET Framework 4 successfully, restarted my computer and tried Eraser setup again.
Installation procedure tells me .NET Framework 3.5 SP1 or higher is required and ends installation.
What is wrong?
Why cant I download .NET Framework 3.5 SP1?
Why does Eraser not recognise / continue installation with .NET Framework 4?
What is shall I do?
 

DavidHB

Active Member
I'm afraid these are, at least in part, questions for Joel to answer. What I do know is that Eraser is developed in Visual Studio 2008; resources are are not currently available to the Eraser team upgrade to Visual Studio 2010 (there's a link for donations in Joel's signature!). Version 4 of the Framework goes with VS 2010; I thought that it was supposed to be backwards compatible, but there may be issues in your installation. Version 3.5 is installed with Windows 7, and it's probably best to stick with it unless you know that you need Version 4.

Based on Joel's earlier answers to questions on this kind of issue, I'd try the following
  • Uninstall both Version 4 and Version 3.5 of the framework;
  • If there is no uninstall option for Version 3.5, download a standalone install file for 3.5, run it to 'install' 3.5 again, then run the uninstaller that will be created;
  • if you can, run a registry cleaner to detect and remove orphan entries left behind by the uninstallers;
  • reinstall version 3.5.

Best of luck!

David
 

Joel

Active Member
Top