6.0.8 Recurring Tasks Run Only Once

Not open for further replies.


New Member
I've had this problem with 6.0.7 b1893 and upgrading to 6.0.8 b2273 hasn't solved it. I'm running Win7 Pro x64, with Eraser started at logon via an elevated CMD prompt.

I have a Recurring Task set to run daily. It runs successfully the first time after Eraser is started, but doesn't run again, though the scheduler says it is set to run. Example: my system was booted on the 5th, and Eraser's task did run on the 6th. It's now the 9th, but the Recurring Task list shows the task set to run on the 7th (with status Completed.)

If I Open Eraser from the system tray and view the log for the task I've never seen any log entries shown (at Informational and higher), though the drop-down session list does have an entry showing each day the task has run. (And the gaps in the session list show clearly the many days the task has not run).

What might be wrong here?

Thanks - I've noticed this too but couldn't corroborate my observation. Could you please file a bug? It appears that recurring tasks only run once per session.
Is there a problem with the Trac account creation system? I created a Trac account, but I still haven't received the confirmation email that will let me create a ticket. I've tried giving it 3 different email addresses, include a Gmail address.
This seems to be a continuing problem. Garrett, whose server this is, can find nothing wrong, but reports like yours keep recurring. It's very mysterious.

Well, Garrett now has a reproducible case to work with, so maybe it's time to solve the mystery?
Well, he doesn't have a reproduce case I guess... and I'm not sure of his server setup, it's all really complicated from my POV.
The Trac problem is reproducible in the sense that my attempt to receive a confirmation email has now failed 4/4 times (I just tried another Gmail address which doesn't contain any puncuation), so it would seem that I can create a failure on demand.

Perhaps someone else can submit a ticket for the recurring task bug?

Yeah I know where you're coming from, and I also know his point of view... it sucks. Anyway, yeah I'll document it as a bug.
Not open for further replies.