Access is denied, 5.8.7 & 6.0 RC5


New Member
I have a bunch of old hard drives I'm trying to erase. In most cases they are old "C:" drives. Here are some of the error messages I've been getting. I've included one of each type, but in most cases there are several different files with the same error (most are "Access is denied.", hence the subject):

Failed: G:\Program Files\Adobe\Reader 8.0\Reader\AcroRdIF.dll (Access is denied.)
Failed: G:\WINDOWS\$NtUninstallKB828741$\catsrv.dll
Failed: G:\WINDOWS\$NtUninstallKB921503$\spuninst\spuninst.txt (Insufficient system resources exist to complete the requested service.)
Failed: G:\WINDOWS\inf\1394.inf (The request could not be performed because of an I/O device error.)
Failed: G:\WINDOWS\inf\1394.PNF (There is not enough space on the disk.)

When I attempt to overwrite unused space, I don't get any error message other than "Failed:" for several files. Here is an example:

Failed: G:\Program Files\Adobe\Reader 8.0\Reader\AcroRdIF.dll

In all cases above, I cut and pasted the entire line. Nothing is left out. These are all from version 5.8.7. Version 6.0 RC5 gives a slightly different format to the same "Access is Denied." messages.

The drives I'm trying to erase are in an external enclosure attached via firewire (IEEE 1394) to a Dell machine running Windows XP SP3. There are no errors in the Device Manager and I can read and write to the drive (i.e. it appears to be mounting correctly). I'm running Eraser as a user with administrator privileges. I've tried both Eraser 5.8.7 and 6.0 RC5.

Some files it asks to delete upon reboot. It appears to delete some files after reboot, but I'm still left with a bunch of files it can't delete.

I don't understand how files can have "Access is Denied." when I am not using the file system on the drive. I don't even list the folders on the drive after a reboot. I just go right in to the Eraser application and try to erase the rest of the files. No luck.

I've had this same problem on two different disk drives. And I've received the same error messages. I even tried running Eraser in Safe Mode, but I can't figure out how to mount an external drive in Safe Mode.

I suppose I could format the drive, but my understanding is this doesn't necessarily remove all the files on the drive.
Are the drives running NTFS as their file system? Furthermore, given time, drives may accumulate errors - those Access Denied errors may be due to the files already having been corrupt.

If you want a deep erase (ie, complete clean such that the partition is erased of its filesystem) then DBAN may be a better solution for you.