bigbro's eraser context menu shortcut does not work


New Member
The right-click context menu shortcut for eraser no longer works on my XP Pro SP3 32 bit machine. It displays in the menu, but nothing happens when chosen. The only option that does work is "Erase on Restart" when I right-click the Recycle Bin. Can you run me through some steps to restore this option?

Have you tried reinstalling Eraser? Or repairing the install?
Which version of Eraser is this, sorry?

And hope you're fine after being discharged.
I have Win 7 Ultimate, and this happened to me also.......drove me crazy for several months until I figured out what was causing it.
In my case, and most likely other cases, the shell extensions were at fault; specifically a third party extension by Systran.
To diagnose and fix this, I used NirSoft's shexview ( to isolate and disable the offending shell extension.
I ran shexview and disabled all non-Microsoft shell extensions, which made the context menu work again, at last (YEAH).
I then added them back one at a time, and after logging off or restarting, I checked if the context menu was still working.
It took a while, but I finally found the shell extension that was causing the problem, and I left it set to disabled.
I hope this information is helpful, it worked for me, and I tried everything possible before this!
P.S. Just remember to log off or restart before checking if the shell extension that you just disabled or enabled has any effect.
Hi alb1954,

Thank you for your posting.

I'm seeing the same behaviour, nothing happens when I use the Eraser context menu (cursor would spin for a while and nothing happens to the file I'm trying to delete, which is my own file, i.e., no permission issue for sure). I already ran Eraser as administrator, too. Dragging and dropping a file into the Eraser window also does not do anything.

Which shell extension(s) did you end up having to disable? I just ran ShellExView and it's showing 256 entries. I'm using W7 Enterprise.

Thank you in advance for any help.