Can Eraser 5.7 or 5.8 to work on a 64 bit AMD machine?


New Member
I just got Eraser 5.7 and tried to setup a scheduler task to daily erase the temporary internet files stored in c:\Documents and Settings\Bob\Local Settings\Temporary Internet Files. I opened the Scheduler and selected "new task" and got the Task Properties dialog. On the data tab, I selected "Files on Folder" and clicked the browse button. I double clicked C: and then "Documents and Settings" without any problem.

But when I double-clicked "Bob", the screen started fluttering and finally stopped with "Bob" still highlighted. But it would not show any of the folders underneath "Bob". If instead of double-clicking "Bob", I right-clicked it, I got the Eraser error message "Exception ACCESS_VIOLATION ...".

So, then I downloaded the 5.8 Beta version. I went to the website, clicked download for 5.8 beta and was given a selection of software to download. I have a 3800+ AMD Athlon 64 X2 Processor running on Windows XP Media Center. So, I chose the file eraser58setup64.exe .
Then I uninstalled (via "Add/Remove programs") eraser57, rebooted and ran eraser58setup64.exe. But it stopped the install saying that it could not run on this version of Windows.

From all of this experience, it seems that Eraser may have some problems wtih AMD 64 bit machines. Has anyone here had success getting Eraser 5.7 or 5.8 to work on a 64 bit AMD machine?
Thanks in advance.
I don't have a 64bit computer, but I think I have spoted your mistake. When you removed Eraser 5.7 did you also remove from the registry the "Heidi" key or folder.
Thanks Carver.

No, I did not. And I just did a search for it and found it under Hkey_Current_User\Software\Heidi Computers.

So, should I just highlight the Heidi folder and then press delete?
Thanks again for your help.
I did delete the Heidi key and its subdirectory named Eraser. Then when I ran the install for Eraser 5.8, it stopped again as it had done before. Do you have any other suggestions?
I did find a file in Windows\Prefetch named
1. Should I delete this file?
2. Are there any other files in this directory or any other) that I should look for (and perhaps delete)?
Thanks Carter,
I deleted the file and ran the Eraser58setup again and got the same error message as before. I guess Eraser will not work on AMD 64 bit machines yet. If anyone finds differently, I would love to be notified. Thanks again.
My pleasure., And you could delete it and see if that was the problem, i f it isn't you can restore it from the recycle Bin.