Cannot find eraserl.exe


New Member
in windows/system32. Need to find it to use with sandboxie.

i am using windows7 64bit and running eraser 6

Please help.
Eraser 6 doesn't use Eraserl any more. Run Eraser /? instead. The command line interface is very complicated as of now, so I'd suggest you use alternative methods to get your files erased (especially with the scheduler being more flexible now, that shouldn't be an issue.)
When I try "eraser /?" I get the message "Unknown action: /?" With the old version I was using

eraserl -silent -file Passwords.txt

is there something similar I can do in eraser 6? I tried looking for command line docs but did not see them. I am running 6.1 1787

ken.martin said:
I tried looking for command line docs but did not see them. I am running 6.1 1787
Given what Joel says, it's perhaps not surprising that the relevant section in the Help PDF is just "TBD". But it would be nice to have some information, even if it comes with a health warning.

Eraser 6's command line interface is a bit like SVN: it's Eraser <subcommand>

The subcommand you're looking for is "help".
I'm having the same problem. I use 7 ult. 32 bit (on a 64 bit chipset), but still it says "cannot find eraserl" Also, for some reason I'm apparently not the Administrator of MY pc (I'm sure it's a 7 thing and probably has to be invoked). There "should" be a Sandboxie forum here because apparently they make some connection somewhere as Eraser (even though it's open source) can be invoked (ostensibly) by a click on the Sandboxie control, and obviously people want to use the 2 together. I'm no programmer...I'm no script kiddie either so I'm not going to take random scripts left by other users and try to invoke them on my machine. I have the script from Sandboxie to put in the field where the button should auto put it but if it doesn't do that then how do I know if it's even working?
Guess I'll start doing my homework...and own work.
Good luck
There is no Eraserl.exe in Eraser 6, which is now the only supported version. Also, there is no connection, and never has been, with Sandboxie, which is outside the scope of this forum. The Eraser 6 CLI is under development; anyone who wishes to use it for production purposes will need to follow subsequent changes rather carefully. But, if you wish to use it, just run 'eraser help', and you will get a list of parameters and switches.

The 'administrator' issue is fully explained in the FAQ (it's a big change for people coming to Vista or Windows 7 from XP).