Cannot install ANY v6.*


New Member
I have hit a brick wall with this.

I tried installing the latest nightly build in order to give Eraser v6 another try since it previously caused crashing and there was NO uninstall option in the Windows 7 64 'Programs and Features' applet so I had previously tried to manually uninstall it and reinstalled an old 5.3 version. Anyhow I ran the 1891 nightly build and it installed fine. I then tried to uninstall it to see if it would clear out any previous crap from the other versions. It uninstalled fine and rebooted.

I tried to install it again but this time it gave the following error.


So I tried to manually uninstall it by removing every instance of it from the hard disk and every instance I could find in the registry, shortcuts etc. It still will not install. I tried rebooting using msconfig to disable everything but the installer service. Same. It says it's got and older version installed even though it's the same version being reported. I rand SFC /scannow and rebooted. Same issue.

I then tried to install other v6 installs and got the following.


I also tried to install both Eraser6.2 r1707.exe and Eraser and get this error.


I have given up for now and installed 5.8.8 which gives me a problem in that the erase menu and move menu does not appear in Total Command my preferred file manager. Reinstalling 5.3 and copying the files from the 5.8.8 64bit directory over the 32bit folder files works fine and gives me the erase context menu back in Total Command (But not the move menu however that never showed anyhow in Win7 64 ever). I copied the 64bit files into the 32bit folder so that when the context menu calls it calls the 5.8.8 files and not the 5.3 files. I don't know if this will cause any problems but I can't see why since it's just a pointer and you can run these as portable files anyhow.

So in summary.
All v6 no longer install.
The previous install of v6.0.6.1376 had no installer and would crash at startup.
The previous install of v6.2 r1707 installed but had no uninstaller however it was installed and would run but would BSOD Win7 64 after being left running for a few hours.
The context menu is lost from use in Total Command (But appears in Normal Explorer from what I recall).

Basically v6 needs a cleaning tool to remove every instance of previous installs rather like some AV componies provide or instructions on what to remove from the hard disk, registry etc.

From what I can tell my system is fine. I have run several AV and malware scanners (Malware Bytes, Microsoft Security Essentials, Spyware Doctor, Trend online AV scanner) and done a check of system files and nothing is found.

Any ideas?

P.S. will there be a portable v6 so we can avoid all this installation rubbish?
Well well well. What have we here. 5.8.8. 64bit crashes my system too. I get no warnings. No BSOD actually. The computer just resets by itself. I know it's Eraser as I removed v6 previously for the same offence and reinstalled 5.3. No crashes. But as soon as I installed 5.8.8 and left it installed for a while the computer reset itself. I noticed 5.8.8 installs MS Visual C++ 32bit and 64bit runtimes. I wonder if they have anything to do with it?

I am going to test if I can copy over the v6 files off a 32bit system and see if they run on a 5.3 install. I know. Probably not and not installed correctly. I just want it's erasing abilities etc. I don't want it running at startup and being installed at all really. Such a mess.

Well that did not work. I am at a complete loss now and have wasted most of my day on this. I have gone back to 5.3 and then copied over the 32bit 5.8.8 folder and it seems to run OK. Anything Eraser v6 or Eraser 64bit completely borks my system. I have no other problems with any other applications. Win7 64 has been running VERY smoothly for a few months now and this is the first application to bring it to it's knee's. I am not going to wipe the system over this one application that will not install or run correctly.

Oh well. Guess I will come back in another 6 months or so and see if things have improved. It 'was' an otherwise great application. It still is (At least in earlier 32bit builds). Shame really.

If anyone has any good suggestions other than a system wipe I will be glad to hear them.
As I'm doing beta testing, I regularly uninstall and reinstall Eraser 6 on my machines (Windows 7 x64, Vista x64, and XP Pro x86), and have never experienced anything like the problems you have encountered.

Here is what the Eraser manual says about removing Eraser completely from your system:

In the event that you wish to remove all traces of Eraser having been installed on the computer, perform the steps below to ensure a more thorough clean up. This assumes that you already have uninstalled Eraser.
1. Delete all registry entries under HKCU\Software\Eraser 6
2. Delete all files under %LOCALAPPDATA%\Eraser 6
3. Repeat steps 1 and 2 for every user on your computer
Of course, simple deletion may not be up to your threat model. If a more thorough clean up is required, do consider erasing your entire drive.

Ignoring the last sentence (which I included for completeness), did your previous attempts to remove Eraser include steps 1-3? Do they help? I'd guess that, with a broken installation such as yours, you'd need to clean the failed installation fully out of your system before successfully installing any version of Eraser in future.

The symptoms you describe suggest to me (though again I'm guessing) that, in your case, Step 2 above may be quite significant. If the reference to the environment variable %LOCALAPPDATA% means nothing to you, you need to tick the box on Control Panel|Folder Options that enables you to show hidden files and folders, then simply type "%LOCALAPPDATA%\Eraser 6" into your Start menu Run command. Delete everything in the folder which then opens, and repeat the same process for every user account on your machine if there are more than one.

Hope this helps,

Deadman's problems sound like a corrupt MSI registry database. Eraser 6 uses Windows Installer and works on test machines I have set up. No code for the MSIs are written in-house and we use the stable Windows Installer MSI (WiX) project's tools.

Moving forward, it seems like you'll need to get a copy of the MSI cleanup tool:
I have installed the MSI cleanup tool. I cannot see anything about Eraser there. I have an erLT which I do not know what that is. Anything to do with Eraser? Any other bits of Eraser that might be called something else?

If that's the case you may want to apply diagnostic logging (google around, I can't remember offhand, either) and run the MSI package and post the log. This however does seem outside the league of our code and more of the particular MSI databases you have on your computer.
I finally managed to install the latest build. However since 5.3 onwards I am experiencing the same issues with BSOD's. I don't know whether it's Eraser or some other issue like bad memory. I have completely uninstalled Eraser and a few other things besides and will see if I can remain stable for a few days. I also did a long test on the hard disk using the manufacturers testing application and it passed fine and several virus and malware scans. I will do a memory test too at some point but it will take a while with 8GB. It is weird how my probems began when I 'upgraded' Eraser from my old 4.3 build though.

P.S. Eraser 5.8 and 6+ do not work with Total Commander anymore (Eraser does not appear as a right click option). 4.3 used to work in Total Commander just fine.
Yes, Total Commander is a reported issue (on Trac already, IIRC) but I'll need to find a way to reproduce the case... I'll try to get it working by 6.0.8.
That's nice to know. However I cannot get my system to run stable with Eraser installed at the moment. As stated I uninstalled Eraser and thus far no BSOD's. Each and every time I have had BSOD's after running a few hours while Eraser was installed (Even though Eraser was not running in the system tray as I removed it from startup). This makes no sense to me unless Eraser puts something else in that loads at startup like a driver etc (Please tell me what else loads if anything so I can troubleshoot this if possible)?
I suggest that you start by doing as full an uninstall as possible, eliminating as many traces of Eraser as you can find from the file system and Registry; a Registry cleaner such as the (freeware) CCleaner can be useful for this purpose. This will get you back to a somewhat more predictable base.

The next thing is to install the most recent nightly build of Eraser 6.1, which is a development version and so contains debug code, and produces crash reports. Also, use the setting in Windows (sorry, I've forgotten the exact details, but you can Google for it) which disables the immediate reboot of Windows after a BSOD. Then, if you get the BSOD, you can see the details of the error message and Google on the error code, which is sometimes useful. If you do get a crash, you can then look for a crash report in %LOCALAPPDATA%\Eraser 6\Crash Reports; it should be in a folder named from the date/time of the crash. Of course, with a BSOD, Eraser may not get the chance to generate a crash report; in that case, all you will have to go on is the BSOD details.

To answer an earlier question, Eraser has a running process which, AFAIK, is always present. If that process is causing BSODs, there is something clearly amiss with the Windows setup, as Windows is supposed to trap program errors to prevent fatal crashes. As you will have gathered from Joel's earlier replies, these issues can be frustratingly difficult to pin down. It can't be the Eraser code as such, as then we'd all have the problem.

From your descriptions, I'm inclined to believe your problem is more hardware-based, since failing hardware does produce wrong results (which can corrupt files, and yes, cause BSODs)
Except I do not have any BSOD's without the newer versions of Eraser being installed. Which makes me think it's a clash with another application or driver. Seriously. Without the later builds of Eraser installed the system is rock solid. I am going back to good old 5.3. At least it worked and did not crash my system for whatever reason it may be.
Deadman said:
Except I do not have any BSOD's without the newer versions of Eraser being installed. Which makes me think it's a clash with another application or driver. Seriously. Without the later builds of Eraser installed the system is rock solid. I am going back to good old 5.3. At least it worked and did not crash my system for whatever reason it may be.
I am inclined to agree with your diagnosis, and am certainly less sure than Joel that this is a hardware issue (FWIW, my money would be on a system setting that was somehow broken during the original install of Eraser 6). But reversion to v5 must now be regarded as a short term workaround, rather than a solution.

With the issue of Version 6.0.7, active support for v5 ceased. This is understandable (and explained on the web page); essentially, the code base of v5 has gone beyond its "use by" date and the Eraser team just does not have the resources to work on two very different versions at one time. Because Eraser has to go much closer than most programs to the boundary of what the OS allows, there is always the possibility that, with a new release of Windows (or even a routine update), Eraser 5 will stop working, permanently and without a fix. This is less likely to happen, in my view, with XP than with later versions of Windows; for one thing, from now on there will only be limited updates of XP.

I don't know how recent your installation of Windows is, but I'm of the school that regards a complete re-installation once in a while as the only effective means of maintaining or restoring OS performance; that is, incidentally, one reason why I always prefer to have physically separate drives for system and data. It might be wise to regard your experience with the Eraser 6 installation as a gentle reminder ...

This is Windows 7 Ultimate 64 bit version installed onto a brand new hard disk only a couple of months ago. As stated I have had no problems with anything. No crashes. Nada. I have stress tested the system and I run quite intensive applications in both terms of CPU usage and memory usage (I have 8GB onboard). No problems whatsoever.

This only happened when I installed v6+ without uninstalling v5.3 first. Subsequently it BSOD's with any v5.8.8 version upwards (Yup it BSOD's with 5.8.8 too). After removing v6 versions and 5.8.8 and reinstalling 5.3 I am rock solid again. It's been running great and the event viewer shows no errors where previously it was full of crashing services and other spurious events all whilst v5.8.8 and/or v6+ were installed.

What does that tell you?
Deadman said:
What does that tell you?
That when I said
DavidHB said:
my money would be on a system setting that was somehow broken during the original install of Eraser 6
I was likely on the right track. But if I were in your seat, I'd leave things as they are at present, and hope for the best. Only if 5.3 actually breaks would I do a radical uninstall of Eraser 5 and try again with Eraser 6, because that would very likely involve diagnosing BSODs. And you are going to have to look for something that goes quite deep into the system (e.g. the runtime libraries) if it causes BSODs in the first place.

From what you say, the issue seems to be as much with something left behind by the 5.3 installation as with the new versions, which is why your case is (I hope!) a bit of an exception. Eraser 6 is now generally pretty comfortable running under Win 7 x64. It mouths off a bit when bone-headed Windows security features prevent it from doing its thing as fully as it would like, but what else do you expect from a brash youngster (and I'm not talking about Joel!)?

Which is why I would like a complete rundown on what Eraser installs and how to manually remove every shred of it's existence from my system before retrying v6+
Joey can you please provide information on what Eraser adds during install. At least that way if I clean it out entirely and install v6+ and it still crashes I know it's not because of some previous install.
Which might be a reasonable request, except that life is not that simple. Eraser, like other programs, depends on a set of Windows and Microsoft infrastructure. The set of relationships that might exist in any given installation is both variable and complex; I believe that it is actually impossible to document fully the whole set of relationships which a given software application might have with the rest of its host system, because there are so many possible dependencies. Short of deleting everything and restoring a full system backup, it is unlikely that you could ever completely revert to the status quo ante.

That said, a list of files, folders and registry keys to delete after an uninstall would be useful. This is partly provided already in Annex D to the Eraser manual, and I think that Joel has published other information on the forum. But the information all needs to be in one place (an expanded Annex D?), and it also needs a list of major dependencies (such as the runtime and the installer), together with details of how to restore them to default condition. Those would cover all the main bases, I think, and provide a good (but not 100%) probability of effecting a functionally complete removal/reinstatement of the application.

On that note. I think a stand alone version of v6+ would be useful. Of course I don't mind if registry entries are made for shell integration but am unsure that would be possible (Not knowing much about how shell calls are made from Explorer and whether it needs more than just a few registry entries). Drag and drop to a stand alone app would suffice if less somewhat convenient.
The main things Eraser v5 adds are the program files itself - C:\Program Files\Eraser\*, as well as C:\Windows\System32\erasext.dll and C:\Windows\System32\Eraser.dll, and a few HKEY_CLASSES_ROOT entries for shell integration (ersfile, .ers), and shell extensions (IIRC, a ShellExt key in *, urlfile, lnkfile, folder and drive.) v5 also installs the Microsoft Visual C++ Runtime libraries (the default installer for 5.8.8 comes with VC++ 2008 SP1 with ATL vulnerability updates) and is installed using the Inno setup library. Program settings are stored in HKCU\Software\Heidi Computers Ltd\Eraser\Version (5.8.8, etc.)

v6 is even simpler: files are only added in C:\Program Files\Eraser. The rest goes into the registry, with the same keys used for shell integration and extensions as v5. v6 depends on the .NET framework, the Bootstrapper installs that before installing Eraser proper. Eraser also depends on the same VC++ runtimes so the installer installs that. The installer is written using WiX. Program Settings are stored in HKCU\Software\Eraser\Eraser 6.

IMO, it's almost quite impossible that you can have an unclean install. Eraser's a simple program, by enterprise application standards.

As to why 5.8 and later crashes, but not 5.3 -- until we have a crash dump or at least a stack trace, it's going to remain a mystery. I'd need at least some clues. Install and BSOD or install and crash or install and hang won't do. As mentioned, Eraser is developed on the same environment you are on, with tests run on Vista (x86 and x64) Any crash would be due to software conflicts within your computer, or hardware failure (as my computers have a tendency to do)