Cannot Remove Eraser Portable


New Member
I want to install Eraser to my desktop PC. I have Eraser Portable in a folder on a limited user desktop and several mentions of "Eraser" in my registry. I am instructed to uninstall all eraser items before proceeding with the installation of Eraser However neither "Heidi" nor "Eraser" appears in Windows Add/Remove list or in Revo Uninstaller's application list.

How do I clean up the old Eraser stuff so I can install the latest version of Eraser ( at this time)? I don't want the portable version at this time.
If you've used Portable it should not be writing anything to the registry and only to the ini file in the Eraser folder. The registry references are probably leftovers. In any case, so long the old version of Eraser is removed from the system it should be alright.

I had run CCleaner successfully 2 weeks ago for regular maintenance. I since tried installing Eraser and got message that installation could not proceed because I was not administrative user. I AM the administrator. I guessed that this was a roundabout way of telling me I still have remnants of previous installation of Eraser. I found "eraser" in several file names on root drive and in the registry. I ran CCleaner again; it found one superfluous registry entry (not mentioning Eraser) and deleted it. I executed Eraser installer again. It worked this time. Who knows why? As Mr. Spock would say, it isn't logical.

C Cleaner's add/remove did not have Eraser in list to remove, as Windows add/remove list and Revo Uninstaller did not either.

I mistakenly put this into thread "Eraser will not install."
I think you are using Vista, right? Usually when the installer complains about no admin rights its diagnosis is usually correct - if you were using Vista maybe you didn't run the installer as an administrator? I'm kinda speculating because I've never seen such an issue before...