Can't access files to erase them



I have WinXP and just installed Eraser 5.7. When I try to erase a file, no matter what the file extension (even simple txt files) I get this message every time: "Failed: <file path> (The process cannot access the file because it is being used by another process.)"

Can anyone tell me what's wrong and how to fix it?

Addtional information

I've discovered that I can use Eraser if I move a file to the desktop. But if f I move it to any other folder, I still can't use Eraser on it. Also, I can't "erase" from the desktop folder -- i.e., by going through the path C:\Documents and Settings\<user name>\Desktop. This makes no sense to me, since I thought that the desktop and the desktop folder were the same thing, but there you have it.

Any idea whether this suggests a reason for my problem?
The files are being used by another process. You need to:
1. Download/install Spiderbite (Free) from: Spiderbite eliminates all traces of your web browsing from your computer. It removes the cache files, cookies, and empties the index.dat file that stores the addresses you've visited.
2. Erase Unused Space using Eraser. Right click on the Drive in Windows Explorer and choose 'Eraser unused space'.
I have another program that does what Spider Bite does, but thanks for the suggestion. I've downloaded Spider Bite and will do a comparison with what I have already. Also, I'll erase the unused space and report back on whether that changes things.

In the meanwhile, someone else suggested a solution. I won't post his name, since I don't know that he cares to have it bandied about in forums to which he doesn't post, but if anyone's interested in the thread, it's in the group at GRC. Here's what he said:

this is actually very common in XP. what is happening is because you have clicked it, the Explorer interface is trying to generate a preview - ie,
reading the file - and is holding it locked.
either turn off the preview, or create a non-previewable file
(folder/no-extension-file or whatever) and ctrl-click it then erase the
"group" - you really dont' care if the new file goes or not, as long as
the other file is selected but lacks the focus....

I didn't entirely follow this (for example, I don't know how to turn off preview -- I don't see anything on "preview" in the WinXP help file, except in regard to graphics), but it led to a relatively easy way to erase the file. I still don't know why this works, but here it is.

I discovered that if I highlight both the file plus a second file -- one that I can normally erase on its own -- I can erase both of them. Also, if I make a copy of the torublesome file, and delete the extension to either the orginal file or the copy (doesn't matter which), I can then highlight both files and erase them at the same time. I can't erase a file if I only delete the extension for that single file and try to erase it all on its lonesome. However, if I give it an extension for a type of file I can normally erase (e.g., .bmp), I can erase that single file, even though I can't erase it with its proper extention. Conversely, if I give, say, a .bmp file (which I can normally erase on its own) a new extension, one for a file that I normally can't erase by itself (such as .wpd, .doc or .txt), I then can't erase it.

All very strange. Anyway, I don't have time tonight, but tomorrow I'll clean out stuff and erase the unused space to see if I can then erase word processing documents without doing a work-around.

I would try opening Eraser (keep it on the Desktop without minimizing it) and then open the Task Manager and "End Process" on explorer.exe. Eraser should now be able to remove anything from your PC I think. Anyone ever try it? (Also, make sure you reboot or Log Off and back before doing this in case it don't work right away.) After you are done maximize the Task Manager again, click "File" "New Task" and then type in explorer.exe. It should work on index.dat. I also would download and install WinClean at C:\ click it and Log Off and Log On twice and in XP it will remove the Temporary Internet Files, Cookies, History, and Temp folder from your main profile at a Command Prompt. Pretty cool 'eh? Go to (It's a great web site to check out anyway!!)
I would try opening Eraser ...

Well now, that led me to another discovery. I normally don't open Eraser at all; if I want to erase a file, I simply right click on it and select erase from the context menu. But when I went to try your suggestion, I discovered that I didn't have to go through the exercise of shutting down explorer.exe. I was able to create a task, navigate to the file, then run Eraser on it, and it worked fine. Not as fast as right-clicking, but it worked.

Which now raises the question: why would Eraser report that another process is using the file when I try the right-click method, but not when I open the program and erase it that way?
I just tried using Eraser by ending explorer.exe from the Task Manager but it did not work. (All the buttons were grayed out.) I don't think it's that big of a deal, I still think using Eraser is lot better than installing Norton on my PC!!
FightingBob said:
why would Eraser report that another process is using the file when I try the right-click method, but not when I open the program and erase it that way?
Simply because the program that keeps locking those files is Explorer, which you are running when using the shell extension (i.e. right-click -> Erase).