Can't erase recycle bin


New Member
I'm trying to use Eraser for the first time. I am trying to clean files off my now-replaced computer before donating it. (But I don't want to remove all the programs and operating system.) I downloaded Eraser yesterday and began by erasing email. That worked ok. Then I tried to erase the recycle bin. I left it going when I went to bed, and this morning it said only 11% complete and did not appear to be doing anything. I stopped it (if I remember right, I had to use Task Manager to stop it). I tried looking for a solution on this board and didn't understand much of what I read. I tried unchecking cluster tips, and then it made it all the way through the recycle bin, but had a list of 949 failures -- I suspect that was the entire contents of the recycle bin. I should have saved the report, but didn't know to do that. But the bin is now empty. I put a few more items in the recycle bin and tried to erase it again. This time I saved the report. It has 6 failures, erased area = 0 bytes, cluster tips = 0 bytes, data written = 0 bytes, write time = 0.00 s.

What does this all mean? My recycle bin is empty but hasn't been overwritten? And why not?

What I was going to do next was overwrite all unused space on my C drive. Can I go ahead and do this, or do I need to do something else with the recycle bin first?

Thanks for any help.
Are you the only user on your computer? I believe that the error is because Eraser is trying to erase the recycle bin of other users (this has been fixed in version 6).

You can run the unused space erase any time, it doesn't depend on anything.