Can't erase unused disk space..


New Member

I have stumbled upon this issue:

I have tried to delete unused disk space on my internal data storage drive (my main drive and storage drive are connected via AHCI). I used 1 pass of DoD following by 1 pass of Pseudo erasure. After that, I tried to see if I am able to recover any data using R-studio, and to my surprise I was able to recover 100% of it. What could the problem be? Am I doing something wrong?


P.S If it helps in any way, my main drive is SSD and the storage is a regular 1 TB HDD.

Edit: I tried one more Pseudo erasure, what I noticed was happening is that the Eraser fills my HDD completely with 221 mb files (about 200gb of them) and after that the process finishes in about 2-3 minutes, removing the created files.
On an SSD drive eraser cannot be used to wipe individual files and there is no guarantee the same blocks are written to as the ones read from.
The free-space erase should clear the data from the empty parts of the drive but note: on an SSD one pass is enough and be aware that over provisioning could lead to some data remaining.

Are you certain R-Studio recovered actual valid files and not artifacts? I'd be interested in more test results.