can't install eraser 6.1 builds -Windows Installer Service


In Vista x64, tried both 6.1.2276, 2278. Same err:
"Windows Installer Service could not be accessed." Said, "can occur when running in safe mode or if windows installer not installed correctly."

Not running in safe mode. Windows installer ver is 4.5 & seems to work fine for installing other apps (even after Eraser install failed).

I'd had trouble uninstalling an earlier eraser ver before trying to install these builds. But, went thru all manual steps of completely uninstalling all traces of v5 & any that existed when 1st attempt installing v6 failed (weren't many instances for it - none in registry).

Tried install again - same err. Installing from admin acct. Really don't think it's a windows installer prob, unless Eraser has a prob w/ this (pretty recent) version of MSI.

Any suggestions?
Re: can't install eraser 6.1 builds -Windows Installer Servi

The Eraser installer simply unpacks two MSI files, which then (obviously) look for the Windows Installer Service. I think that is set by default to Manual, so it needs to be started for the relevant MSI file to load. That is clearly where your problem lies; either the the installer service is not present or disabled (you can check this via Task Manager), or it is failing to start for some reason. In the latter case, you could try starting it manually, to see if that helps.

There have been so many installs of Eraser that if the MSI file(s) as such were faulty we'd know about it by now. But cases such as yours are in fact rather unusual.

Re: can't install eraser 6.1 builds -Windows Installer Servi

Thanks David. To be clear, it's looking for msiexec.exe?

I find 2 exact copies of it - same date, ver, size, installed date - one in Win\system32 & one in win\sysWOW64. Both are v4.5. Windows or windows updater installed them there- not me.

In Services, find only one entry for Windows Installer - w/ the path \system32.
It is set to manual start in Services.
the system32 ver of msiexec shows running in task mgr - when or after Eraser install fails.

That said, to date, had no probs w/ any other apps (x86 or x64) installing. Whatever differences between Eraser's 6.1.x installer vs the many other apps installers I've used lately (x86 & x64), they had no prob "Not being able to access Windows Installer Service." None failed at all, for any reason, except Eraser. To be honest, not sure if some apps use the local ver of windows installer or include their own- probably former.

There's DEFINITELY something diff about what / how Eraser does or looks for during installation vs all the other apps. Maybe Eraser's (since installing on x64 OS) looking for the entry in Services in the \sysWO64 path? Whereas no other app installers have a prob w/ that entry not being in Services.

I usually install all apps to D:, so tried installing Eraser BOTH to it's default path C:\Prog Files\Eraser & D:. Get same err about windows installer.

On one install try, after closing eraser failure notice windows, saw a pop up notice window that'd been hidden - said, "Eraser can not find specified path," but don't know for sure which path - didn't say. Either way, all paths selected during install attempts do exist.

After manually del all "remnants" of Eraser, I rebooted & tried again. Just to be safe, shut down KIS & all other apps. Tried it now w/ 2 separate d/l's of 2 diff ver of Eraser 6.1 builds- 2276, 2278 - doubt it's corrupted files.

Does / can Eraser create an installation log to find out real problem(s)?
Re: can't install eraser 6.1 builds -Windows Installer Servi

EDIT: Just installed x64 ver of Eraser 5.8.8 again. It installed / runs perfectly.
Installed it to non default path (as other vers) in D:\Program Files.

During setup of 5.8, noticed it clearly said was installing core files for eraser 32 bit AND 64 bit (mentioned syswow64 during setup). Maybe v5.8.8 uses the 32 bit ver of windows installer, but v6.1 is looking ONLY for a windows Service for 64 bit msiexec? Where as most other 64 bit apps can apparently find / use 32 bit msiexec w/o problems), since there's no entry in Services for 64 bit windows installer?

But the default path 1st chosen by v5.8.8 was C\Program Files (not Program Files (x86).

If so, not sure what the solution is. Assume I could create ? a Services entry for 64 bit msiexec? Not sure how, or if would be a conflict, since when Vista d/l & installed the latest vers of both 32 / 64 bit files, it didn't create an entry in Services for the 64 bit file (by mistake or design).

Side note: When only ONE app out of dozens is complaining about not being able to access a file that nearly every app uses for installation, it's probably not a windows problem. It's a problem w/ the app's installation process.
Re: can't install eraser 6.1 builds -Windows Installer Servi

If I remember correctly, Eraser 5 does not use the same installer as Eraser 6, so the fact that Eraser 5 installs may not be particularly significant.

I'm afraid that this now has to be one for Joel, as he understands the internals of the installer much better than I do.

Re: can't install eraser 6.1 builds -Windows Installer Servi

I'll get back to you at the end of today.
Re: can't install eraser 6.1 builds -Windows Installer Servi

Still no ideas why Eraser 6.1 seems to be the only app / 64 bit app out of dozens I've installed that has a problem accessing the windows installer service?

David, I think your idea about Eraser 5.8 & 6.1 using different installers may be the exact reason I can install 5.8 but not 6.1.
Re: can't install eraser 6.1 builds -Windows Installer Servi

Yes, Eraser 5 uses the Inno installer, for the builds released by me. The first thing you'd need to do to debug this is obtain those MSIs. I'll show you how.

You'd need WinRAR or 7-zip. Force either to unpack the installer you downloaded, within you should find 2 MSIs, one for each architecture. Extract the x64 one to a folder, say, D:\Downloads. Then, browse to the folder using Windows Explorer, right-click on the blank white area of the window while pressing shift and select Open Command Window Here.

In the command prompt, type:
msiexec /L*vx "Eraser (x64).msi"
A log file should appear in the same folder. There shouldn't be sensitive info in that file (unless environment variables are), you should be able to upload it here.

While you're at it, you can try installing TortoiseSVN. TortoiseSVN uses the same Windows installer Eraser uses (and the same development toolkit: WiX) so if Tortoise is affected then it's an Windows Installer issue... if it doesn't then it is an Eraser installer issue which the log should point out.
Re: can't install eraser 6.1 builds -Windows Installer Servi

1st, I'm back to not receiving email notifications of forum replies. I would've replied sooner to your instructions. Was prob for a while, then after I mentioned on forum, it stopped. Now same prob. Haven't changed email address. I receive all bulk / spam mail for that acct. In user CP, under setting "Notify me upon replies by default," is set to yes.

Here's the msi file you wanted. Currently, trying to install latest eraser 6.0, rather than the Tortoise svn mentioned. Wanted to uninstall 5.8 1st - uninstaller thinks eraser's still running - it's not. May try reboot.

When unpack the x64 msi installer & enter the command, msiexec /L*vx "Eraser (x64).msi", all I get is what's below.

Windows ® Installer. V 4.5.6002.18005

msiexec /Option <Required Parameter> [Optional Parameter]

Install Options
</package | /i> <Product.msi>
Installs or configures a product
/a <Product.msi>
Administrative install - Installs a product on the network
/j<u|m> <Product.msi> [/t <Transform List>] [/g <Language ID>]
Advertises a product - m to all users, u to current user
</uninstall | /x> <Product.msi | ProductCode>
Uninstalls the product
Display Options
Quiet mode, no user interaction
Unattended mode - progress bar only
Sets user interface level
n - No UI
b - Basic UI
r - Reduced UI
f - Full UI (default)
Help information
Restart Options
Do not restart after the installation is complete
Prompts the user for restart if necessary
Always restart the computer after installation
Logging Options
/l[i|w|e|a|r|u|c|m|o|p|v|x|+|!|*] <LogFile>
i - Status messages
w - Nonfatal warnings
e - All error messages
a - Start up of actions
r - Action-specific records
u - User requests
c - Initial UI parameters
m - Out-of-memory or fatal exit information
o - Out-of-disk-space messages
p - Terminal properties
v - Verbose output
x - Extra debugging information
+ - Append to existing log file
! - Flush each line to the log
* - Log all information, except for v and x options
/log <LogFile>
Equivalent of /l* <LogFile>
Update Options
/update <Update1.msp>[;Update2.msp]
Applies update(s)
/uninstall <PatchCodeGuid>[;Update2.msp] /package <Product.msi | ProductCode>
Remove update(s) for a product
Repair Options
/f[p|e|c|m|s|o|d|a|u|v] <Product.msi | ProductCode>
Repairs a product
p - only if file is missing
o - if file is missing or an older version is installed (default)
e - if file is missing or an equal or older version is installed
d - if file is missing or a different version is installed
c - if file is missing or checksum does not match the calculated value
a - forces all files to be reinstalled
u - all required user-specific registry entries (default)
m - all required computer-specific registry entries (default)
s - all existing shortcuts (default)
v - runs from source and recaches local package
Setting Public Properties

Consult the Windows ® Installer SDK for additional documentation on the
command line syntax.

Copyright © Microsoft Corporation. All rights reserved.
Portions of this software are based in part on the work of the Independent JPEG Group.
Re: can't install eraser 6.1 builds -Windows Installer Servi

Sorry, I think then it should be
msiexec "Eraser (x64).msi" /L*vx
Re: can't install eraser 6.1 builds -Windows Installer Servi

I got Eraser 6.1.2278 to install. Looks to be working but haven't verified any erasing.

AFAIK, went thru same exact listed steps of del any remnants of eraser from folders for all users & from registry key before installing. Didn't work before - this time it did. Obviously something I did or w/ my system was diff - nothing I'm aware of, but can't invest time trying to figure out what. For now, seems to be working.

Re: forum email notifications. I did get notice after Joel's last post correcting the command string. Joel, did you or other admin do something last couple days to make it start working again? It's same email address been using all along. No messages get filtered out for that acct on my end. I'd kinda like to know, since it's a recurring prob. Thanks.
Re: can't install eraser 6.1 builds -Windows Installer Servi

No, we've left the system as it is AFAIK. I don't think Garrett did anything either. Anyway, glad it works for you. The L*vx switch actually enables logging, nothing else.