cant use new eraser


New Member
I'm in despair. I used to use eraser regularly. Was easy to use, seemed to work fine. I upgraded to latest version and now I'm lost. I run a task (overwright hard drive free space) and the task never finishes. Used to take about 3 or four hours to erase about 170GB. I tried reading the help pages but it's way to technical for me. ALSO, the user interface is confusing and I cannot read all of it. Parts of the menus and printing are overlapped and othes are cut off so I can't read everything. What the heck have you done to this app which I depend on? Is there any alternative which would be as effective that a novice like me can use? Can I have/install the old version again?? Help!
In the FAQ (link below), there are posts, with further links, on 'Getting to know Eraser 6' and 'Common Eraser 6 problems'. You probably find the answers you need there. Also, there is a post on Eraser 6 architecture, which explains why the program is as it now is, and how it is intended to develop.

I too am a former Eraser 5 user, and was initially a bit shell-shocked when I first installed Eraser 6, but a short period of use convinced me that the new, cleaner interface is easier to use, and I do not enjoy going back to Eraser 5. All the main issues with Eraser 6 are now fully documented, and have either been fixed in the development builds or will be fixed in the next full release.

If, after reading the FAQ posts and following the advice there as appropriate, you still have specific queries, please do come back; comments and suggestions should be posted in the 'Programming' forum; this one is for support queries.

Already read bunch of stuff. Lots is over my head. Problems I'm having not addressed. Can't spend MORE time trying to figure it out. Just need something I can download and use (like I did with old version). I never had to read or study with it, just use it. An "upgrade" shouldn't require more study, should require LESS, be easier to use. Can I please have the old one back??
Well, you can download it, and install it. You can even rewrite it yourself, as it is open source. But the fact that the Eraser Team decided that it was not a maintainable product should be telling you that its days are numbered.

And I'm sorry, but with a program like Eraser, which has the capability to do immense damage to your system and data, the "it should just work" approach just doesn't wash; thought, care and understanding are needed. I have suggested that you read a couple of short forum posts, neither of which (given the nature of Eraser) is any more technical than it needs to be. That's a small price to pay for harnessing the power of Eraser safely.

Eraser 6 itself is actually more intuitive and less error prone than Eraser 5, once you get into it. It has issues, which are being fixed, and which do not prevent its use for its prime purpose.

I hear you. Thanks. I'll keep trying. Why can't I read some of the words on the interface? Some stuff is cut off or overlapping. Do I need to reinstall or is that a problem for everyone?
kardenm said:
Some stuff is cut off or overlapping. Do I need to reinstall or is that a problem for everyone?
It's certainly not a problem for most people (including me).

Joel will know the details better than I, but I would guess that the way the window is painted is handled by the .NET libraries and the OS. It would help if you were able to post a screenshot, and also tell us which OS you are using, what size of screen, and whether you have Windows set to use large fonts and/or icons.

Because I suspect that the problem arises from an interaction with OS settings, I rather doubt that re-installation would help. But I could be wrong.

Thanks for the reply David.

I'm using Windows XP, 21" Acer monitor. You may be right about the text size. I believe I have it set to LARGE. I'll check (different computer than I'm using now).

Don't know how to post a screenshot (or even what it is). If someone can tell me how, I'll do it.

Thanks again!
kardenm said:
Don't know how to post a screenshot (or even what it is). If someone can tell me how, I'll do it.
A screenshot is where you save part or all of your monitor view; obviously, having a picture of what is going on can be very helpful. But as that's not possible, we need to try other things.

Ideally, we'd like to know the resolution of your monitor (pixels x pixels), but 21" is reasonably large, so that is probably not the issue. But the fact that you have set large fonts may be relevant.

Please could you give a more precise description of what is truncated or overlapping? If Joel can reproduce the problem, he can maybe fix it.

The text issue should be fixed in the development builds. I tested it on both XP at 125% and Vista at 125%.