Completed with errors

Bavaria 44

New Member
I run Windows 7 on the option "Erase Unused Space" as an administrator, and always gives me this error:
Session: domingo, 05 de enero de 2014 17:21:25
domingo, 05 de enero de 2014 17:21:25 Error The program does not have the required permissions to erase the unused space on disk. Run the program as an administrator and retry the operation.

Me as well. Eraser Team...please help. I also get the "...does not have the required permissions..." error. I've ran as admin from both my desktop short cut and the app within program files. I am not using encryption which I see can be an inhibitor so I know that's not the problem.

Note: When I run Eraser in my recycle bin it works just fine.

Please help. Thanks.

I'm a newbie and I had exactly the same problem. In the Forums I found two fixes, though there may be more. I used both; the problem has been solved and the empty space is happily being erased right now. Though I don't know if it was necessary to use both. I'm on Windows 8.1 and running Eraser Build 6.0.10 with the most recent updates (as at 17 Sept 2014) installed.

(1) In the Eraser FAQ, "Getting to know Eraser 6" is the second topic. It's a useful intro, and begins with the sentence "Read this even if you don’t want to read the manual". Halfway down is the following paragraph: "Running Eraser as Administrator - For some erasing tasks, and in particular when you erase free space on a drive, Windows Vista or Windows 7 may require that you run Eraser as Administrator (also known as 'running elevated'). To do this, first close the running instance of Eraser by right-clicking on the small Eraser icon in the System Tray at the right hand end of the Taskbar and selecting Exit Eraser. Then right-click on the Eraser program icon on the Desktop or the Start Menu and select Run as Administrator. Note that, when Eraser is running elevated, you cannot drag and drop on to the Eraser window from an Explorer window that is running normally; this is a Windows restriction."

(2) I ran a search with the keyword "permissions". The information you need is given in the answers to a question -- fourth down the list -- from alexandra18 titled "unused disc space".

Kudos to DavidHB for the 1st and Garrett01 and GregM for the 2nd.

Yes, this is a complete show stopper. I am the adminstrator. I log in to my own PC. I log into to eraser as my administrator login. Every time ... I cannot even clean up a drive. Please HELP ... !!! I cannot use Heidi anymore and I will try anything else now unless there is an answer.
With some more trial and error I have found that even when Logged in as ADMINSTRATOR you must EXIT ERASER then (right click) on Eraser and RUN AS ADMINISTRATOR. I.e., not enough to just be logged in as adminstrator.
I have logged in as administrator, exited Eraser in the task bar and then right-clicked on the Eraser icon, selected "run as administrator" and I still get the "...does not have the required permissions..." error.Please help (I am running Windows 7)
Even though you close Eraser, and even though you check the Task Manager Applications Tab and Eraser does not appear to be running, it is still running in the background.

You have to go to the Processes Tab in Task Manager and end the program, then Run as Administrator and you will have permission.
I normally work under a standard account (without admin rights), even on my home PC. I ran ERASER** under my account with full admin access, but tasks would not run, similar to the messages above. I just closed the object in the system tray, then right clicked the Eraser desktop icon and selected RUN AS ADMINISTRATOR (even though I was already logged on as an administrator). Eraser then ran as expected. Using File Scavenger and other "undelete" disk tools, no end-user data was visible so it appears to have worked as anticipated. It is an odd glitch that seems to persist in this app. I have never seen that type of application behaviour before. Nonetheless, I am happy it is working. Thanks Folks.

** Eraser Built January 12, 2015
I am disappointed that there appears that there is no Eraser "support" reading & answering this forum. There are several ways of addressing the issues each of you encountered. Anyone experiencing this difficulty may want to read my "post" to this Forum (Install Bug & Enhancement - Registry Entries) on how I solved this problem until the Eraser people can decide
I am disappointed that there appears that there is no Eraser "support" reading & answering this forum. There are several ways of addressing the issues each of you encountered. Anyone experiencing this difficulty may want to read my "post" to this Forum (Install Bug & Enhancement - Registry Entries) on how I solved these problem until the Eraser people can decide exactly which approach they want to use.

<I just experienced some kind of Forum "hiccup" so I hope this posts works correctly>

To make my changes, you need to right-click on "Command Prompt" (in Accessories), select "Run as Administrator", type in "regedit" and hit enter to bring up the Registry Editor. You need to locate the two entries I have identified (HKLM means HKey_Local_Machine) and change the "/" to "-" in the entry built by Eraser Install in one case. In the other case, you have to add the entry I described in my "post". Many people think that making a mistake doing this will destroy their machine but it won't. You just use REGEDIT to correct whatever mistake you made including just deleting everything you added and starting all over again. If you are paranoid, you can create a "backup" of your registry before you make any changes.
Without a doubt, this program was well conceived - in the beginning when everything was dark and void.
Then along some doofus came along and just RUINED this program.
Heidi, do you realize that not everyone runs at 100% zoom in Windows? WAKE UP! Your stupid windows don't show all the contents all the time. That is extremely stupid and useless.
Are you ever going to fix this unending problem with running this program as an Admin? You need to remind people that even though you close it it still runs in the background. Why not remind people about this? Why even do this? Its stupid and petty and insiduous. You know how tortuous Windows is with Permissions. It should be Permissions from Satan. It never works properly. You'd think that if you OWN your OS and OWN your computer and OWN your internet connection you'd be able to set the permisions once and for all. Like I can do anything I want, anytime I want, anywhere I want on my OWN computer. Playing with Permissions is about as much fun as trying to network something in Windows about Window's Troubleshooters? Have they EVER fixed anything EVER? The most useless diagnostic tool ever made in history. Then there's Window's Help. Very UNhelpgul.
Don't be so bloody STUPID. Fix this and inform people and fix the zoom problem. Also the menus are atrociously stupid. Add Data? I'm ERASING a disk! What data am I adding exactly? Its like the person that thought of this was bright and then the project got taken over by dweeb, fumbling aorund like idiots.