Conflict between Eraser 6 and Windows 7 administrator accoun



Systemax desktop with Windows 7 Home Premium (64bit), Service Pack 1.
Since I installed Eraser in late March, my desktop's administrator account allows only a temporary logon with no privileges. I tried removing and recreating the administrator account and uninstalling Eraser, but now I can't even log in to it. It says, "User Profile Service failed the logon and cannot be loaded."
I remember that when I chose "Save" to download Eraser, Windows blocked the file with the message that it was Incompatible. I returned to the website and saw the instruction to choose "Run" instead of "Save," and that worked fine, but what's the deal? Is Eraser compatible with Win7 or not? And how can I fix this? (I am not a techie, let alone a developer.)
Re: Conflict between Eraser 6 and Windows 7 administrator ac

I cannot think why 'Windows' would block the download, nor can I think of anything in Eraser that would affect any form of logon. There appears to have been some issue in your system (or which came from the download site) which prevented Eraser from being downloaded, and that, by definition cannot be Eraser as such.

Did you access the Eraser install file on the Eraser site, or on another download site? Personally, I would never run an executable file from an external site; I'd want to download it and virus check it before running it, and the very fact that it refused to download would make me suspicious.

I have never used the Windows Administrator Account as a normal user account; that is nor what it is for. The normal place to install Eraser is a standard user account with administrative privileges, which, like most utilities, Eraser needs, though unlike some Eraser does not need to run elevated all of the time. Did you install Eraser in a user account, or were you running in the Administrator account when you installed it? In the latter case, if there were anything wrong with the installer, your system would be very vulnerable.

Your symptoms also bear some of the hallmarks of a malware attack, but so many other things look like malware on occasion that I say this with some caution. In short, the symptoms are puzzling, and all the more so because neither Eraser nor the .NET Framework under which it runs are obvious causes. Perhaps Joel can think of something that has not occurred to me.

Re: Conflict between Eraser 6 and Windows 7 administrator ac

Yes, I accessed the Eraser site and chose the above version, which was downloaded from ... e/download. And yes, I was in my user account; I, too, would not download as administrator.

It turns out the problem probably predates the Eraser installation, which was perfectly clean. I just happened to try the Administrator account right after and had not been there for a long time. It's just that I remembered seeing something in the Eraser forum or somewhere about Eraser's causing a similar problem by assuming the Administrator identity for some functions. I wish I could remember where I saw that.

I successfully erased the contents of my Recycle Bin and one small file with great ease. (I liked the program.) However, after uninstalling Eraser, the Recyle Bin files mysteriously reappeared there. Is this normal?

I seek a solution through Windows Answers. Thanks for trying to help.
Re: Conflict between Eraser 6 and Windows 7 administrator ac

Eraser has to be run 'as Administrator' when, for example, you are erasing the free space on a drive. This is discussed extensively in the FAQ, so I shall not go into detail here. Was this perhaps the reference you recall?

Please could you describe the problem with the Recycle Bin in more detail? Which files reappear; are you saying that Eraser does not seem to be working at all? Does the Recycle Bin task appear in the Eraser Schedule (when you open the program); if so, when you right click on the task and select 'View log', do you see any error messages there? I would be particularly interested in error messages that refer to permissions.

Re: Conflict between Eraser 6 and Windows 7 administrator ac

I think you're right about where I saw Administrator mentioned.
I just clicked the Recycle Bin's Eraser icon, and all contents magically disappeared, and all indications showed a complete erase. Perhaps a few days later when my problem appeared, I uninstalled Eraser. Soon after, I opened the Bin to discover all 6 or 8 of the exact files I'd erased magically restored. I didn't bother to check the log either time. Maybe I missed a step.
Really, I think Eraser's excellent and easy to use, at least for the simple tasks I tried. When my present issue is fixed, I'm sure I'll try it again. Thanks again.
Re: Conflict between Eraser 6 and Windows 7 administrator ac

Something on your computer has, I guess, restored the files from copies elsewhere in the system. Did you by any chance do a system restore in the intervening period, or do you run software that can saves snapshots of your system in the background?

If Eraser had failed for any reason, the files would have remained in the Recycle Bin folder. I know from repeated testing (including using a sector editor to examine directly the locations where files previously resided) that once Eraser has overwritten a file it cannot be restored. So there must have been copies of the files elsewhere on your system. In other words, whatever your problem is, it is not likely to be a problem with Eraser.

Re: Conflict between Eraser 6 and Windows 7 administrator ac

I just discovered that I should have gotten back to you back in April. It took forever, but it turned out this problem had nothing whatsoever to do with Eraser. It seems to have been caused by a Windows update. I sure learned a lot figuring out the solution. I finally fixed my accounts in August! All is well now.
Re: Conflict between Eraser 6 and Windows 7 administrator ac

Glad to hear it =)