Constant Accessing of Floppy Drive


New Member

First of all, Great work guys! Appreciate the time taken to develop this.

I'm having a small irritation. I tried to search the forum, but apparently the word 'floppy' is too common and I get no results, so I apologise if this is a repeat, but if not, I thought it may help.

I tried one of the nightly builds - [02 May 2010 17:11:11:51] - and it constantly tries to access the floppy drive. I'm probably a bit old-school having a floppy drive, but just in case you didn't know, you do now!

Any ideas on a fix - am I doing something stupid - or will this be able to be addressed in another build ?

I'm running Win7 64 pro

The lack of replies so far seems to indicate that none of us can reproduce this problem as we don't have floppy drives any more!

Please can you elaborate. Does the attempt to access the floppy only occur when the Eraser window is open, or does it happen all the time (i.e. from the Eraser background process)? With Eraser, a common way of dealing with odd behaviour is to try deleting the Task List (%LOCALAPPDATA%\Eraser 6\Task List.ersx). If that doesn't work, fully uninstall Eraser, delete the Task List (if Eraser has re-created it), and install the current stable build, 6.0.7. If that is still problematic, it will be one for Joel to figure out.

Thanks for your reply David.

Access to the floppy happens all the time. If I end the eraser background process, access stops.

I tried deleting the task list, but it made no difference.

I then unistalled and d/l the stable to install that, but I couldn't install it. Everytime, I got the 'Eraser has stopped working' windows error. The error dialog box disappears before its finished checking, and i can see no further info. I tried cleaning the registry and trying again, but the same. I tired about 5 times, each with the same outcome. I then tried my previous working build, which was - but the same thing happened - 'Eraser has stopped working'. More restarting and registry cleaning [and the app_data/local cleaning] and tried a few more times, but each time the same thing. Finally, I tried again, which worked straight away. However, I'm back to the floppy light going on and off all the time and the annoying click of the drive. THe only option is to end the background process and start eraser as and when i decide to use it. I may try the latest nightly shortly and will let you know if I have any luck.

See the FAQ. Read the top item; there is a link to a thread about installing 6.0 after uninstalling 6.1. Instructions for deleting the Task List (which you need to do) are in that thread.

Thanks David - I should have looked there first before giving up, although I did search the registry, but then settled on a registry cleaner. Nothing beats doing it yourself.

Anyway, I deleted the key and am now using 6.0.7 successfully. No floppy access attempted either, which is great. No I can install the stable version, I''ll try one of the later nightly builds at some point, just to see if it effects the floppy drive too. Not sure how many of us even have floppy drives anymore, but I can't be the only one ... :shock: although it shows how old my computer is. If I had a blanking plate, I would probably remove, but don't want a hole.

Thanks again for you time.

darkgr33n said:
If I had a blanking plate, I would probably remove, but don't want a hole.
You could always leave the drive in place but disconnect it ... :D

It's probably best to leave the 6.1 builds alone for a while; some of these odd errors vanish of their own accord with successive builds.