currently in use...


New Member
I am new with eraser. I have read the getting started faq. Here's the problem I am having. I can successfully erase a single file like a ".doc" file. However, when I try to erase a folder I get a ... Completed with errors; message. Then I view the log for that scheduled erase attempt. The log gives the folder name followed by ... "currently in use and cannot be removed". These erasures are being on a "non C:/Drive". G:/Drive, F:/Drive etc.

Does anybody know what I must be doing wrong? Right at the moment I am aggravated with the program and the initial excitement I had for it.


Which method were you using to erase the folder (there are three; for details see the "Getting to know ..." sticky post in the FAQ)?

If none of the methods work, can you delete the folder to the Recycle Bin and erase that?

The reason for the questions is working out which program is accessing the folder (or indeed if that matters). Bear in mind that we are dealing with a Windows restriction here; all Eraser is doing is reporting that it cannot erase a folder that is already in use.

Thanks for responding David. I have been using both the “right click – eraser/erase” and the Schedule Task method. Instead of actually scheduling the task though I have been right clicking on the task and then selecting “Run Now”. I just now tried the “drag and Drop method” on one of the difficult folders. It erased nicely. Then I tried another difficult folder. It created the same “…currently in use…” issue. Then I deleted that folder to the Recycle Bin. There was no Eraser right click option to the difficult folder. (There are also many other files in the Recycle Bin. It is not empty.) So then I tried “drag and drop” from the Recycle Bin to the Eraser window. Same issue resulted.

Have I done things the way you wanted in order to see results?

David, where should I go from this point? Thanks for your help.

Can't get a reply from David. Does anybody know how to solve the "...currently in use..." issue?

Does the Task log tell you which program is using it? Select the task log entry, right click on it and select Copy Selected Entries.

You can paste it in the forum text box here.