DBAN fails to load after boot



Using DBAN 1.0.3 it boots and then if I type dod or press <enter> alone it displays:

loading kernel.bzi ......................................................
loading initrd.gz...........
Uncompressing Linux... OK, booting the kernel. Please wait.

then the display goes from blue to black and it shows:

devfs_mk_dir (ida/disc0): using old entry in dir: f7ccf0a0 "ida"
devfs_register(disc): could not append to parent, err: -17
devfs_mk_dir (ida/disc1): using old entry in dir: f7ccf0a0 "ida"
devfs_register(disc): could not append to parent, err: -17

Thanks - it is a great product.
Yes it has both a smart 3200 and a smart 3100ES, there are two logical drive attached to each controller with a total of 16 physical drives.

While we are on the subject of smart arrays - I have wiped servers that had "hot spare" drives in them, these drives were not active, they were in an offline status so probably those drives do not get wiped. I guess I could first reconfigure the array controller to have all the drives in use and then run DBAN.

Thanks again for the great utility.
Okay, thanks for the information.

DBAN has had the Compaq Smart driver for a long time, but this is the first report that I've received from somebody that tried to use DBAN with the hardware. These things must be rare.

Given that the driver does not register properly and that I do not have a hardware sample, I'll likely remove the driver from the next release.
Hold on there. It has worked fine in the past, I have wiped more than a couple servers with 3200 and older Smart 2 or 2SL controllers. I don't know for certain about the somewhat newer integrated Smart array or Smart 5x controllers. The Smart 3200 was widely used in Compaq servers for many years, although in the past couple years they have transitioned to the 53xx and other models which use a different driver. The 3100ES is the 'rare' one but I believe is uses the same driver as the 3200. Let me try pulling the 3100ES out, recabling everything to the 3200 and see if that solves the problem. I'll post back when I've done that. Could it also be something with multiple array controllers? Just wondering. Worse case I can always cable everything to a regular scsi controller and run the wipe. Thanks again for the time and effort.
It works with Compaq Smart 3200 Array controller

DBAN works with the Smart 3200 Array controller. I am not sure one way or the other with the 3100ES. The problem was apparently the combination of machine, an old Proliant 7000 with three processors, and the array controllers. It worked under windows but didn't like linux, or more likely my reconfig left something not properly terminated (in which case most times the Compaq boxes won't even boot). Whatever - it is wiping the drives. I set it to use raid 0 and disabled the cache.

Do you have a use for a Smart 3200 controller? If so how can I get one to you?
Certainly. If I have a hardware sample, then it will be better supported.

You can send hardware donations to:

Darik Horn
10 Hidden Court
Brantford, Ontario
N3R 6P4

Please include a note in the package stating that it is a donation for the DBAN project.

UPS, FedEx, and USPS can get packages to that address from the USA without hassles.