DBAN usage problems


New Member
I have an older HP Pavilion XT933 machine with WinME and the typical 60GB drive. I obtained and installed a second 60GB from a friend when his computer died, the exact same model as mine. I've been unsuccessfully attempting to wipe this second D: drive in preparation to take the plunge and install Linux. Hopefully, the following facts will help someone help me.
*The second drive functions fine.
*Initially used the DBAN 1.0.1 version, created through Eraser.
*DBAN boots up fine, reaches the "boot:" prompt screen. I can hit Enter, it loads, and goes to the interactive screen and detects the two drives, but from there, everything stops. It accepts no more input. I can't select, move up/down, verify, rounds, or method with the spacebar, J/K, V, R, M keys. The only keys I haven't tried are the F12 or F10, for obvious reasons.
*I downloaded the later version 1.0.3, installed, created boot floppy, same results.
*I've downloaded the latest keyboard driver from HP. No change.
*Since the boot screen functioned, I diconnected the primary C drive, leaving only the D to be wiped and tried "autonuke". DBAN stopped with non-fatal errors, never showing the interactive/status screen. Oddly, the LED indicating HD usage stayed on, but the error messages indicated DBAN was done and finished almost immediately.
*The non-fatal error run created a log file but I'm unable to view it, having tried Notepad, Wordpad, Works, and a Word-viewer.

This is my first attempt at DBAN/disk-wiping, so I may be doing something in ignorance that's preventing success. I've searched this forum and Googled for solutions with no luck. Any help/direcition would be greatly appreciated.
Do you have a PS/2 keyboard or a USB keyboard?

This usually happens when a USB keyboard is attached to a computer with an old BIOS.

Flash the BIOS to the latest available version, or try a PS/2 keyboard instead.
I have a USB keyboard, the original that came with the machine. When I updated the keyboard driver, I think I noticed an update for the BIOS too. I'll try the BIOS update or see if I can scrounge another keyboard.

Thanks for the advice,