Dec 10th- HUGE catastrophe with version 5.86 please help


New Member
Mods- ive posted this in a few spots since im not sure where it goes..if you wouldnt mind, could you leave it up at least for a day or two in the multiple spots b4 you take them down, so that i can have the best chance, however remote, at having a solution...this is a devastating blow right now as the computer that has been crippled is the main one we use for our home office and losing it, especially now, has been a tremendous loss.

This is very difficult for me. First, thanks for what has always been a really great and such useful program. Unfortunately catastrophic destruction just occurred shortly after i downloaded the newly released 5.86 I knew i should have waited, but it seemed this was the version that weve been waiting for for some time, so i went ahead, uninstalled my prev version, dloaded 5.86, did a system restore, and then did a 1pass pseudorandom pass on only the recycle bin (definitely not the 2kb option that has caused so many problems in the past even though im sure it would be fine by now)

The recycle bin is indeed empty but unfortunately, many files on the rest of my comp are now inaccessible with messages like "wrong format for this program" etc when i go to open them..all types of files ....word, photoshop etc... these are work files i work with everyday that are now completely inaccessible. i ran nothing else during that period and i just see now that some others in the past have had the same problem and some were fixed by system restore.

So i go to system restore, go back to the point i saved, and even bigger catastrophe, i cant even log in since the mouse suddenly wont work! so i cant login...after 20 attempts at restarting including options in safe mode, i finally get one in safe mode that allows me to get into the computer where i am slowly backing up any files that arent corrupted. In this mode however i cannot access internet (im on our other non work computer now) and everything is slower and many programs wont work.

I guess i have learned my lesson and never trust a download again that just came out, but this wasnt a beta and i used system restore, but even then i just shouldnt ever trust. Anyway, its obvious this computer has now been destroyed and my only option is to buy a completely new computer but if ANYONE can think of anything to possibly help i would be so appreciative. The sheer amount of time and work lost by having to transfer what i can save and never recover the files ive lost is so overwhelming to me right now and so many other things in life are going so difficult right now like my wife who is having serious problems in her pregnancy with our first child that it just seems unbearable.

Once again, i dont want to seem unappreciative for a great program that has worked so well for us for years, and i hate to sound so depressing as i have here, but my wife and i both work only from home on the computer and losing the computer and the files while probably inevitable, is staggering to think about.

some quick points in case they're asked:

1) All i did in eraser is 1 pseudorandom pass of recycle bin, nothing else.
2) b4 i installed 5.86 i had to delete the old version 5.82 manually since it wasnt in add/remove menu..all i did was delete the folder..i know there are some dll's or whatever that are left, but would that actually cause the new version to go outside of the recycle bin, randomly select files (i cant find a pattern since not every file is affected) and modify them somehow?
3) Very important- All affected files show a modified date and time during the Eraser scan and now they are unusable, unopenable.
4) No other programs like Kaspersky antivirus or counterspy were scanning
5) Computer has had no problems and yet the system restore actually made things incredibly worse just by going back to the moments b4 the eraser 5.86 install, and even undoing the restore still cripples the system
6) The mouse can work in safe mode but no internet and many other programs wont work, (like our backup software, so we one by one are having to manually backup the files to our external drive)

Any help you all could offer would be appreciated... especially if you know anything about the following 3 things:

1) how to somehow make the affected files usable again
2) how to get on internet in safe mode (i did choose networking option)
3) why system restore to the point b4 installing eraser 5.86 would cripple the mouse making logging into the computer in anything except safe mode completely impossible.

thank you all who make this forum such a great resource completely on your own time as volunteers. Many many thanks for all your suggestions and advice i have benefited from in the past even if you are not able to help us here, you do an incredible service testing the program and constantly helping, on your own time, ridiculous people like me try to recover their sanity.

- Tony
Hi :)

Thank you for your extraordinarily verbose post ! :lol:

Can I just ask what OS you are using please and also 32 – 64 bit ?

Are you sure you installed the latest Eraser 5.6 ?

I am using Eraser 5.6 on XP Pro 32bit with absolutely no problems. I have also been beta testing over the last few versions with no catastrophic problems.

Joel may be able to help you more so I suggest that you don’t do anything else with your computer until he has replied here. There is no point making things worse until we know what has happened.

Hang in there Tony and we will try to work it out. Although I have to say this doesn’t sound like an Eraser problem to me.
more info

Overwriter- thanks very much for responding so quickly. Info you asked for:

1) definitely downloaded 5.86 -followed the link from the announcement in forum
2) running Win Xp 32 bit (home edit?)
3) as for not possibiloty its not an eraser prob- well, i havent had any problems on the computer- then download and run eraser on the recyle bin and immediately cannot access many of my files, all of which show they were modified during the scan, and which i was able to use RIGHT before i did the scan. No other program ran during this time.
4) no other programs like Kaspersky, asquared or counterspy were running scans at the time
5) the errors im getting when i try to access the files are the same type others with past version problems have had " cannot access this file because it is not the required type..etc"

To make matters a complete annihilation, i ran scandisk hoping it could do something and after i could not even login.

Now the only message I get is:

"Windows cannot start because the following file is missing or corrupt:

Windows root>\system32\ntoskrnl.exe

This has been really an incredible turn of events in 24 hours...I go from having a great working computer - then in a grand irony, 3 otherwise trustworthy steps later- 1)downloading latest version of eraser , 2)running a system restore to try to undo the damage, and 3)running scandisk to repair the intial damage and system restore mouse inoperability- now i am left with a completely inoperable system.

I could understand it if i was doing risky downloads and exotic operations here but i avoid all that, dont visit any weird sites, dowload only known files etc, since our life and business depend on that computer and ive always got some of the best security stuff keeping out malware like Kaspersky and Counterspy etc

i very much and humbly appreciate any help that anyone can offer,

Re: more info

skymonk said:
Overwriter- thanks very much for responding so quickly.
Now the only message I get is:

"Windows cannot start because the following file is missing or corrupt:

Windows root>\system32\ntoskrnl.exe

I can't help you personally, and maybe you have done things subsequent to the catastrophe that might make some recovery steps no longer available. However, maybe the info at the following links might help:

Here's a quote from this site: ... krnl/22115

"ntoskrnl.exe is a critical process in the boot-up cycle of your computer although should never appear in WinTasks whilst under normal circumstances Note: ntoskrnl.exe can be altered by the w32.bolzano and variants. If this process appears in WinTasks, please update your virus definitions immediately."

You can find various sites with info if you just type the file name into Google.



I have just tested Eraser on a vritual PC and followed your steps and found no issue. - Erase Recycle Bin (1-Pass Pseudorandom Data)
This calls the following command line
"C:\WINDOWS\system32\eraserl.exe" -recycled -method Random 1

The recycle bin is just a folder on each drive so even the 2k pass will not have any effect.

Are you certain the HD is not in itself corrupt? Have I followed the same process you have ?

Sorry… :oops:

I just noticed in my previous post on this thread I mention Eraser 5.6 instead of Eraser 5.86. :?

Either way though I do believe you have been a victim of a virus and that your circumstance has nothing to do with Eraser although I can see why you may think that considering the coincidence.
I'm sorry to hear your predicament.

I've deleted your cross-posts... since this thread caught the attention of people. Anyway. Viruses are only one possibility. Hard disk age is also another. Hard disks are still the Achilles heel of computers today... unfortunately. In my quick skim I didn't see any mention about hard disk age. Is your disk making noises when operating?

Also I must say a bit about the "download a final non-beta". In practice assuming your hardware and OS is free of bugs, if a program has gone through a few pre-releases as Betas/Release Candidates then the final binary is usually stable. I believe in your particular case delaying the installation of Eraser would not be of much help since the virust/disk was a ticking time bomb

Could this be Kaspersky-related?

The OP mentions having Kaspersky and having run a "scandisk." Well, Kaspersky has had a long-running issue with KAV affecting the running of chkdsk and (allegedly) causing serious problems with some (very few) computers. For more information, see this thread: ... 995&st=520
or TinyURL:

This issue with KAV was never been really resolved, but (I believe), has been eliminated with the latest version. (Although users of previous versions still will have the alleged "damage" left on their systems.) I am certainly no expert on these matters, but I am wondering if this issue with KAV could figure in here, perhaps somehow in conjunction with updating Eraser?

Be that as it may, I am dubious of there being any way out of the situation short of a complete system reinstall.