Deleting Open File - Possible Bug


New Member
I tried deleting a pdf file without noticing that I had it open.
Eraser froze.
Got the Windows7 error message to either debug the program or close it etc., I chose to debug it, got a message about No registered JIT debugger was specified, closed file, tried a second delete with Eraser, got system not responding, opened Windows task manager and clicked End Process on Eraser, window popped up with 'Pipe is broken' (Eraser Shell extension box).
It would be good if Eraser had someway of detecting open files so that dummies like me could receive a warning if we try to delete open files.
As Eraser tries to force files to unlock/close, I'm not quite sure what was going on here. Did the Eraser Task Log show any sort of error (though the log may have been deleted when Eraser Crashed)?

DavidHB said:
Did the Eraser Task Log show any sort of error (though the log may have been deleted when Eraser Crashed)?


Good question, where would I find that log, is it the .ersx file that I see in my App Data/Local folder?

If so, I can send it to you (I was thinking of attaching it but I wasn't sure if I'd be compromising my security).
I do suggest that you read the FAQ, particularly the one on getting to know Eraser 6.

The log is accessed by right clicking on the Task in the Schedule, and selecting 'View Log'. If the task has disappeared, so, I am afraid, has the log.

oops! Will do.
I repeated the process, only thing that showed up in the log was "Completed with errors" (but it didn't delete it because of the crash).
Thanks for trying.
Normally, 'completed with errors' is what shows up on the entry in the schedule. Did you right-click on that to look at the actual log, which will say what the errors were?

No sorry couldn't.
I left the Eraser window open to one side of the screen. When the error message window popped up the Erase window 'grayed' out. It would then close if I selected Debug (or close program).
Although I haven't seen quite these symptoms reported before, it is possible that the crash has corrupted the task file. Delete the .ersx file you found, and restart. Eraser may then work normally. But if there's still an issue with open files, this might be an issue on which Joel has a view (when his other unavoidable commitments allow him time to work on Eraser and post on the forum)

Thanks again DavidHB.
Happy Australia Day everybody.
I duplicated the problem on the laptop which is a bit slower and was able to open the log window before the error pop up message.
All it says is "Could not force closure of file...(file path)".
The settings appear to be 'and only with severity: Information and higher'.
Couldn't click on anything else because of the pop-up(see attached AppCrash).


  • Untitled2.png
    164.6 KB · Views: 1,434
The error message is not unusual; in fact I was able to reproduce it exactly when I repeated your sequence of actions. But, in my case (and with the same OS), Eraser did not crash. I'm afraid I don't know why a .NET dll file crashed in this case, and can only guess that this is is a .NET installation issue rather than one produced by Eraser as such.

Thanks David.
I suppose it wouldn't have anything to do with UAC being turned on (Windows 7) or Admin privileges? I run the computer as an Administrator.
In Windows 7, having Administrative privileges does not mean that you run programs 'as administrator'; you have to do that explicitly (or set a program to run elevated).

I don't think UAC is the issue, but I have it turned off on the machine on which I did the comparison. Later, I'll try to do a comparison on my other machine, which has UAC turned on.

To me, the fact that the crash report pointed to one of the .NET dlls suggests an installation issue. Which is not good news, as those can be a real pain to debug.

I see.
Strange that the problem should occur on two separate machines.

Desktop was a clean install with Win7 Pro, Laptop was upgraded from Vista Home Premium to Win7 Home Premium.

Erase was a clean install on the desktop but can't remember how I installed it on the laptop.
Did you use the same install download for both machines?

By the way, I ran my test on the machine with UAC enabled. Same result: no crash.

DavidHB said:
Did you use the same install download for both machines?

Unfortunately I can no longer remember.

It seems to depend on the file type on my computer.
Pdf files will do it and it doesn't matter if I'm using Foxit reader or PDF Xchange viewer.
Png files are ok if they're opened in MS Paint or Paint.Net.
Word documents if open in Word 2007 (.docx) will Crash Eraser if you try to delete these while they're open.
I'm as near certain as I can be that the Eraser code does not differentiate between different file types; there is no need for it to do so. So the issue has to be with the runtime. Or, just conceivably, with the way the offending file types are registered. But that's a guess.

Thanks again.
I'll just have to put up with it and be more careful before I Erase files.

I'm glad that it doesn't end in a total computer crash. After I close the crash pop ups and close the open file, Eraser behaves itself when used again on the same file from the context menu. It also reappears in the system tray.
Over to Joel ...

Come back to the forum, Joel. We're missing you .. :(

I think it's also due to the anti-virus installed. What were you running? I've seen such crashes before but I can't pinpoint what goes on -- two kinds of code are at play here (.NET and native code) so it's not exactly the easiest to debug, either.
Hi, I have Avira AntiVir in the background.

I'm also adding two text files with details from Windows Event Viewer, I hope it helps.

Let me know if there is anything else that I can do.


  • Net Runtime.txt
    467 bytes · Views: 45
  • AppError.txt
    504 bytes · Views: 35