Didn't Erase


New Member
My HD failed a few weeks ago and now I need to send the old one back to the manufacturer. I want to delete the stuff on it, mostly banking and tax info and such. My important info has been recovered from the old HD and it has been formatted.

I've downloaded Eraser, fixed the run as admin issue, and also the permissions to the old HD. After fixing these things and changing the plausible deniability settings with some random, unimportant files, I ran the eraser on the old hard drive. After the hours it took to complete, I opened my data recovery program and was still able to find all the files, programs, and even preview pictures, etc.

So what can I do to get this erased? Sorry if this is on the FAQ or elsewhere on the forum. I've looked and can't seem to find anything else that may help me besides what I've tried above.

This particular query is not in the FAQ, so your post is entirely appropriate. However, it would be useful to know what, if any error messages you had in the Eraser task log after the Eraser free space erase.

Eraser works through the file system; if that is non functional because the drive has failed, Eraser cannot access the drive. You do not say how the drive failed, or whether it is still accessible in any way. Clearly, if you formatted it, it has been at least partly accessible.

If the drive is now inaccessible, the cost of either ensuring that the data is gone (e.g by degaussing) or restoring the drive to a condition in which it can be accessed is likely to be prohibitive. I had this situation some years ago, and have always regretted letting go of the defunct hard drive that I could not erase; while I never had any comeback, the inherent insecurity of the situation was an inevitable worry. Now, the cost of hard drives is such that I prefer to make them non functional myself (by opening them up and scoring all the platter surfaces) and to forego the free replacement.

If the drive remains accessible, you could well have been caught out by the System Restore/Shadow copies feature of Windows. A free space erase will not touch shadow copies of deleted files contained within a Restore point, because the space they occupy is not marked as free by the file system. If you had explicitly erased your test files, they would be gone. If running a file recovery program does not turn up any of the confidential data you really wanted erased, then that will have been removed by the free space erase. To be absolutely sure, and if the state of the drive allows it, you could quick format it again before running the free space erase once more. As, after the format, there will be no shadow copies, running a file recovery program immediately after the erase should not turn up recoverable sensitive data, unless a partial drive failure has made areas of the drive readable but not writeable.

The hard drive had a damaged or lost partition.

I formatted before erasing before, but was still able to access all the data with the data recovery software. I can try it again, but it sounds like the case may be that the HD is not writable.

I'm actually over the time allotted to send the HD back, so I should be getting a bill sometime soon. If I can't figure anything out soon, I may end up just paying for the new HD and keeping my old one, but I really don't want to have to pay for the new one. I was just worried since I was told my old HD may be refurbished.

I'll try formatting the HD and running eraser again though.
Did you try deleting the lost partition with diskpart, or anther utility?

As I'm not very computer savvy, I didn't know about that. I ran eraser again yesterday with the same results (and no errors on the log).

I went ahead and downloaded DBAN and ran that last night. This morning, I plug the old HD in to the USB to try and check to make sure everything was erased and my computer doesn't even recognize the HD... So I tried it on my desktop and my data recovery tool detected the hard drive, but it has moved from "damaged partition" to "lost partition." It's scanning it now for files.
If you were able to set up and run DBAN, you are probably more computer savvy than 90% of users ... :)

I'm a bit puzzled by the state of your hard drive. You don't seem to have an obvious hardware failure. My guess is that the partition has become corrupt; basically, a partition is a logical construct that maps all or part of the drive to a logical device (in Windows, a drive). Getting rid of that partition and creating a new one might restore the drive to health. At that point, Eraser should work.

Removing the partition can be done in the Windows Disk management applet.

Another possibility is that of potential confusion over the "free space" vs. "normal" erasures. If you have formatted your disk, you should be using an unused space erase to get rid of the old data on the drive.

Of course, most of these only work if the drive works as advertised... if the drive has a potential failure, then most guarantees no longer hold.
At the start of the thread, the OP said
qwert said:
... I ran the eraser on the old hard drive. After the hours it took to complete ...
I took this to mean that a free space erase was being run, and advised accordingly.

Based on what is reported so far, I still think that there may be an issue with the partition table, rather than with the drive hardware as such. But diagnosing these things at a distance can be a bit hit-and-miss.