disk full


New Member
i have windows 7 netbook 100G C drive. i was running eraser on free space 35 passes.

it ran for more than 24 hours and It was successfully erasing. The job completed 90% and seem to hang on some system file for more than 6 hours.

i checked and my hard disk was is was almost full. so I cancelled the job.

Do i need to run the eraser again or has it erased most of the free space.

your help would be appreciated.
i ran it again with 1 pass. after the disk has no space left (0) eraser seems to hang at around 90%. is there a solution for this or has this done the job erasing.
This is explained in the FAQ; start with the post on common Eraser questions. You need to make sure that you delete any erasing files that remain.

For free space erasing, with a modern hard drive (which you will have in a netbook), there is, so far as the Eraser team are aware, no need for more than the default single pass erase. Do you know what the task log or error message said? There are a number of possible causes of the problem, and the scenario will be a bit different if you are running XP rather than Vista or Windows 7.

From what you say, I'd guess that free space is all, or nearly all, erased, but that the unused entries in the MFT have not been cleared. The normal way to check whether anything significant is recoverable is to use a file recovery program such as Recuva. However, because NTFS in particular is rather complex, even a successful erasure of free space may not remove all traces of deleted files; the system often stores part or whole copies of such files in space not marked as free. Recuva has a facility to overwrite files it finds, which can be very useful in such circumstances, and is a useful complement to the Eraser free space erase.


thanks for the reply.

I ran the eraser again. waited a little patiently and the job finished successfully with. This time it removed all traces of the files including the files in MFT.

Previous time when I stopped the job there were some files still in MFT. i used Recuva to find the files and overwrite but I could not overwrite using Recuva because the current revuva cannot remove form MFT.

Anyway, thanks again for the support.
Yes, the 'try again' method is worth a go, and I should have mentioned it in my reply.